Reply
 
Thread Tools Display Modes
Old 06-03-2016, 03:16 PM   #1
Junior Member
 
Join Date: Jun 2016
Posts: 10
Wildcat 32qbt fridge not working

Hi folks. I have some how lost use of my fridge. I am hear the flame going and it doesn't get cold. I have propane and stove works. What am I to look for to test?


Thanks James
__________________

__________________
Minty is offline   Reply With Quote
Old 06-03-2016, 03:22 PM   #2
Senior Member
 
Join Date: Feb 2015
Posts: 594
The make and model of the fridge would be a start.
__________________

__________________
2016 Flagstaff 23lb
Toddupton is offline   Reply With Quote
Old 06-03-2016, 03:41 PM   #3
Junior Member
 
Join Date: Jun 2016
Posts: 10
It's a dometic. Not sure of model but it has a thermometer inside attached to fins to adjust temp
__________________
Minty is offline   Reply With Quote
Old 06-03-2016, 04:59 PM   #4
Senior Member
 
Join Date: Feb 2015
Posts: 594
How old is it? Does it work on electric? Any yellow powder in the back?
__________________
2016 Flagstaff 23lb
Toddupton is offline   Reply With Quote
Old 06-03-2016, 05:39 PM   #5
Junior Member
 
Join Date: Jun 2016
Posts: 10
Sorry. Typing and working. It is a 2011 got it in 2010. No yellow powder. Flame is going but sounds like wind is blowing it. I have not tried power yet as I only noticed it last night and never had a chance today. I'm going to power and try blowing out the port to make sure no debris is in it.
__________________
Minty is offline   Reply With Quote
Old 06-04-2016, 08:58 AM   #6
Junior Member
 
Join Date: Jun 2016
Posts: 10
Ok I've had a little bit of time and looked. I have a Dometic 2852. Fridge was made in 2010. I plugged the trailer in and the freezer started to cool. So I think that part is ok. Sadly I mostly dry camp. I hooked the propane back up and left it. When I left I noticed the thermofuse. There was a black tip in the middle of the terminals. Not sure if that is a reset but pressed it any way. I want back this morning and it seems to be keeping freezer cold cold but the fridge is only at 5 Celsius. Better than 20 c so I moved the thermistor up higher and will check later today. Any thoughts as to why it just quit.
__________________
Minty is offline   Reply With Quote
Old 06-04-2016, 09:03 AM   #7
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 3,415
It might be that you lost 12V to the unit and when you plugged in things worked, check out your batteries and connection.
__________________

__________________
Retired Navy
Jake my sidekick (yellow Lab)
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM of Idaho
SeaDog is offline   Reply With Quote
Reply

Tags
cat, fridge, wildcat

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:51 AM.