Thread Tools Display Modes
Old 04-06-2011, 05:14 PM   #1
Junior Member
marobrown's Avatar
Join Date: Mar 2011
Posts: 7
ZX75 Display

When The DW wife and I took out our Shamrock for our first trip, the second night the radio would display the alarm time and the display and buttons stay completly lit, previously when I turned off the power everything went dark. How do I go about fixing this? I have been pulling the fuse everynight. Also is there anyway to get the remote to work better?
marobrown is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:53 PM.