Reply
 
Thread Tools Display Modes
Old 07-14-2013, 07:43 PM   #1
Member
 
JackRAbbit's Avatar
 
Join Date: Oct 2012
Posts: 33
16K Reese hitch issue

When I unhitched my 5th Wheel after this weekend the handle to release the hitch got stuck open. It only took a little tap on the clamp to release it. I have always had some minor issues with it on both hooking up and unhooking. Has anybody experienced this? And is this something that I should be concerned about?
__________________

__________________
JackRAbbit is offline   Reply With Quote
Old 07-14-2013, 07:47 PM   #2
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Have you lubed all the pivot points?
__________________

__________________
OldCoot is offline   Reply With Quote
Old 07-14-2013, 08:40 PM   #3
Member
 
JackRAbbit's Avatar
 
Join Date: Oct 2012
Posts: 33
No I haven't greased the pivot points. I never thought of it. Do you think that could cause the clamps "stick"?
__________________
JackRAbbit is offline   Reply With Quote
Old 07-14-2013, 08:48 PM   #4
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Definitely, I took my hitch plate off and turned it upside down and lubed every pivot on it plus the big pivot pin on the hitch frame. Sprayed a little lithium grease on the jaws and on the sides of the chute even though the pin doesn't rotate in the clamp.
__________________
OldCoot is offline   Reply With Quote
Old 07-14-2013, 08:57 PM   #5
Senior Member
 
B and B's Avatar
 
Join Date: Jun 2013
Location: Wilmot Twp, Ontario, Canada
Posts: 8,604
Quote:
Originally Posted by JackRAbbit View Post
No I haven't greased the pivot points. I never thought of it. Do you think that could cause the clamps "stick"?
Hello, I had the clamp stick upon unhooking the first time. The dealer did not lube anything up at all. It just was about half an hour ago.

B
__________________
B and B is offline   Reply With Quote
Old 07-14-2013, 09:13 PM   #6
PPST OGCDG
 
Frank-VA's Avatar
 
Join Date: Sep 2011
Location: Between I-95 & The Great Dismal Swamp
Posts: 2,163
I do the same thing that OC does. I have a slider so I Lube the rollers on the slide and the latching mechanism for the slide.
__________________

__________________
Frank- VA {:-{)
2004 4x4 Ford 6.0 PS, SCC, SB
2005 Wildcat 29 RLBS
Frank-VA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:16 AM.