Thread Tools Display Modes
Old 06-16-2015, 03:00 PM   #1
Senior Member
HONDAMAN174's Avatar
Join Date: Jun 2011
Location: Big brown desert
Posts: 1,987
Primus iq blowing fuses?

Trying to help a family that is traveling. 07 ridgeline with primus iq controller and factory connects harness. With controller connected and no trailer, stop lamp fuse blows. Connect trailer, doesn't blow. Replaced factory connector harness and sent them on way that "might" be fixed. Just received call from Zion that all was fine until they unhooked then fuse blew again.

I'm thinking controller is bad- any other thoughts?
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:10 AM.