Reply
 
Thread Tools Display Modes
Old 06-01-2017, 12:00 PM   #1
Junior Member
 
Join Date: May 2017
Posts: 10
new to me 2006 Charleston 400QS

Newest owner of 06 Charleston 400QS. On shakedown cruise last weekend I managed to zorch the inverter. I think the generator was running and I plugged into daughter's house with 50A to 15A adapter and heard a bang. It tripped the house GFI so I reset it and tried again. Tripped it again. Now no inverter output or indicator light on inverter. Chassis batteries are too low to start engine so there I sat. Finally paid $50 dollars to local RV dealer to come out and jump it to get engine started to see if alternator was working to charge chassis batteries so I could at least go back home(450)miles. So the questions are...I assumed I could run generator and plug in shorepower at same time. Am I wrong. Is there an issue with transfer protocol or equipment? I see there is a box with two contactors that should switch between generator and shorepower? Does the inverter charge the chassis batteries or is that just the engine alternator? New inverter to be delivered today. I did a "soft" and "hard" reset/reboot of the old Magnum Energy ME 2012 inverter and the "on" light came on and I measured 13.3V but no current.
__________________

rwr218 is offline   Reply With Quote
Old 06-02-2017, 12:29 AM   #2
Junior Member
 
Join Date: May 2016
Location: Eagle River, Alaska
Posts: 11
There is a reset button on the inverter. Sort of like a resettable fuse. I thinks it's in the upper left corner of the inverter, but you may want to look around it. It's a kind of restart. I had the same situation with inverter indicating voltage but no current. That reset switch corrected the problem.
As for running on generator and plugging into shore power is not something I would recommend. Judging by what I know about transfer switches, you'll run into a phase difference of the two power sources and that can with damage or kick off that fuse.
The inverter runs a charger for the batteries. When the engine is running, the alternator also charges the batteries.
I hope that helped.
__________________

Rick Neff is offline   Reply With Quote
Old 06-02-2017, 08:29 AM   #3
Junior Member
 
Join Date: May 2017
Posts: 10
Thanks for the reply Rick N. I tried the reset and no luck. I just installed the new inverter last night along with two new chassis batteries. Expensive lesson. Everything works as designed. Engine leaps to life now. So I can cross those two things off of the list. Now I have 100 other things to address. Keeps me busy in a good way.
rwr218 is offline   Reply With Quote
Reply

Tags
charleston

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:01 PM.