Reply
 
Thread Tools Display Modes
Old 11-28-2014, 10:59 PM   #1
Junior Member
 
Join Date: Nov 2014
Posts: 7
Two issues with my '14 charleston bh430

1st - the rear ac units had an exhaust smell coming through the system today. Any ideas as to why this would be the case?

2nd - after flushing the toilet won't stop running/filling. Had to turn off the water pump and can't connect to city water either otherwise toilet will overflow. Any suggestions?

Thanks
__________________

trentkimball is offline   Reply With Quote
Old 11-28-2014, 11:06 PM   #2
Ret E-9 Anchor-clanker
 
donanddona's Avatar
 
Join Date: Jul 2012
Location: Genoa, ILL
Posts: 1,475
1st did you look around the outside to see if someone was burning in the area? I have had to "jiggle" my foot valve to stop the filling process.
__________________

__________________
Don & Dona W/yorkies Gizmo, Master Chief, & Tali
2011 Flagstaff 8528 BHSS 2015 Ford 6.7 XLT
2010 Full Timers & Still Going
donanddona is offline   Reply With Quote
Old 11-29-2014, 06:45 AM   #3
Junior Member
 
Join Date: Nov 2014
Posts: 7
The exhaust smell continued until we shut off AC units. Nothing outside caused the smell. I tried jiggling the handle and had no luck. Any other suggestions would be welcome.
trentkimball is offline   Reply With Quote
Old 11-29-2014, 05:42 PM   #4
Senior Member
 
gasman94's Avatar
 
Join Date: Oct 2012
Location: Southwestern Mi
Posts: 1,228
If your setup is the same as a Berkshire, you should be able to shut off the toilet in the water manifold compartment. It's inconvenient, but will allow you to use the rest of the plumbing system.
gasman94 is offline   Reply With Quote
Old 11-29-2014, 06:08 PM   #5
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
What toilet do you have ? I can't imagine what the smell would be. If there is do smell outside it might be the filters were exposed to a exhaust smell. You might try cleaning them.


Sent from my iPhone using Forest River Forums



Phil57 is offline   Reply With Quote
Old 11-29-2014, 09:51 PM   #6
Junior Member
 
Join Date: Nov 2014
Posts: 7
Thanks gasman. I shut off the toilet. Now I just need to get that toilet fixed. I cleaned the air filters and the smell no longer is coming in.
trentkimball is offline   Reply With Quote
Old 11-29-2014, 09:59 PM   #7
Junior Member
 
Join Date: Nov 2014
Posts: 7
I have the dometic toilet. See pic of the bar code. Click image for larger version

Name:	ImageUploadedByForest River Forums1417316361.213721.jpg
Views:	207
Size:	787.6 KB
ID:	66952
__________________

trentkimball is offline   Reply With Quote
Reply

Tags
charleston

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:05 PM.