Reply
 
Thread Tools Display Modes
Old 05-17-2018, 06:48 PM   #1
Junior Member
 
Join Date: May 2018
Posts: 2
A/C Fan will not shut off

I have a 2012 Forester with a Dometic A/C and Single zone thermostat. My A/C fan will not turn off in any position (Cool/Furnace/Heat Pump)with fan in Auto. I have followed all the suggestions on different forums and thermostat instructions without success. Can anyone provide possible causes / solutions to this issue?
__________________

EACOMS is offline   Reply With Quote
Old 05-17-2018, 06:51 PM   #2
Senior Member
 
cavie's Avatar
 
Join Date: Apr 2016
Location: Port Charlotte Fl
Posts: 1,829
Quote:
Originally Posted by EACOMS View Post
I have a 2012 Forester with a Dometic A/C and Single zone thermostat. My A/C fan will not turn off in any position (Cool/Furnace/Heat Pump)with fan in Auto. I have followed all the suggestions on different forums and thermostat instructions without success. Can anyone provide possible causes / solutions to this issue?
If you really have it in auto you need an AC tech. He does not need to be an RV tech.
__________________

__________________
2002 27rk Wildcat 5er.
Port Charlotte Fl/Hinsdale Ma
Newley Retired.
cavie is online now   Reply With Quote
Old 05-17-2018, 07:35 PM   #3
Member
 
Join Date: Oct 2017
Posts: 40
I had one of mine do that before and it was the control board. Located in the lower part of the ac unit. Needed the model number off the unit to get the right one, that was located on the top unit under the shroud.
Pretty easy change out. If you do replace any part please turn off the breaker before doing anything. Hope this helps.
whitewinghunter is offline   Reply With Quote
Old 05-21-2018, 07:03 PM   #4
Junior Member
 
Join Date: May 2018
Posts: 2
Fixed

Whitewinghunter, I took your advice and decided to replace the control box. While I was trying to make sure I had the correct A/C model number, I discovered that the control box and thermostat that were installed on the unit we not correct. The box and thermostat were designed for a unit with a heat pump, when in fact the unit did not have a heat pump. I ordered the correct box and thermostat, installed it, and now it works properly. Thanks for the suggestion.
EACOMS is offline   Reply With Quote
Old 05-21-2018, 09:01 PM   #5
Member
 
Join Date: Oct 2017
Posts: 40
Glad you got it working.
whitewinghunter is offline   Reply With Quote
Reply

Tags
fan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:56 PM.