Reply
 
Thread Tools Display Modes
Old 04-08-2017, 03:26 PM   #1
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,568
Dash Air Bag light stays on! Ford E450 2015

Just when I thought "All's Well!" with no more issues, the Air Bag light comes on for a few seconds like it should when I start the engine and goes off. Then it comes back on and stay on. I checked all the connections under both seats. Look like I'm going to have to make a trip the to Ford Dealer after all. There are no trouble codes flashing on the dash and the Air Bag light also doesn't flash an error code. Any thought?
__________________

__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 12 trips 38 nights
2018 Camping 8 trips 30 nights
Sagecoachdriver is offline   Reply With Quote
Old 04-08-2017, 08:29 PM   #2
Senior Member
 
LinandLen's Avatar
 
Join Date: Sep 2016
Location: Central Coast, California
Posts: 330
We were having the same issue when we first picked our RV up. It's a 2016 Ford E450. Lately the idiot light has been staying off though. We're not bringing it in. We have body work that needs to be taken care of and slide out adjustments. We still have yet to take ours out on a camping trip.
__________________

__________________
Linda and Lenny
2016 Forester 2861DS
1995 Jamboree 31N (2000)
1979 Tioga 25' bunkbed (first RV in 1992)
LinandLen is offline   Reply With Quote
Old 04-08-2017, 09:29 PM   #3
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,568
Quote:
Originally Posted by LinandLen View Post
We were having the same issue when we first picked our RV up. It's a 2016 Ford E450. Lately the idiot light has been staying off though. We're not bringing it in. We have body work that needs to be taken care of and slide out adjustments. We still have yet to take ours out on a camping trip.
Sorry to hear you need those fixes. Great spots along the central coast, Jalama, Pismo and Morro Bay. Good luck!
__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 12 trips 38 nights
2018 Camping 8 trips 30 nights
Sagecoachdriver is offline   Reply With Quote
Old 04-09-2017, 02:37 PM   #4
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,568
Of course after I ordered a OBD SRS code scanner, I went out and played with the driver's seat belt retractor connections and the light went out. May keep the scanner anyway. That's a relief as I was dreading having to take the MH into the Ford Dealer.
__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 12 trips 38 nights
2018 Camping 8 trips 30 nights
Sagecoachdriver is offline   Reply With Quote
Old 04-09-2017, 10:34 PM   #5
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,568
Good news!

Tester came late this afternoon. Ran a test and it came up with a Passenger Seatbelt buckle pretensioner Deployment control error. But it has cleared. Guess I'll make the DW ride in the back from now on! Loose connection I hope!
__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 12 trips 38 nights
2018 Camping 8 trips 30 nights
Sagecoachdriver is offline   Reply With Quote
Old 04-10-2017, 07:00 PM   #6
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,568
Quote:
Originally Posted by LinandLen View Post
We were having the same issue when we first picked our RV up. It's a 2016 Ford E450. Lately the idiot light has been staying off though. We're not bringing it in. We have body work that needs to be taken care of and slide out adjustments. We still have yet to take ours out on a camping trip.
Read that the yellow connector under the passenger seat can be the problem and just by pushing it back in can solve the issue. I think that was my problem as that was one of the first things I did. I believe it took a while form it to reset the dash light. I haven't cleared the error code.
Scanner says

Status-13
Open circuit
Status-08
Fault previously detected not currently present
__________________

__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 12 trips 38 nights
2018 Camping 8 trips 30 nights
Sagecoachdriver is offline   Reply With Quote
Reply

Tags
light, ford

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:32 PM.