Reply
 
Thread Tools Display Modes
Old 11-28-2015, 02:30 PM   #21
Senior Member
 
Join Date: Oct 2015
Location: Wisconsin/Florida
Posts: 793
Camera Moisture

Is it possible that the moisture is on the external portion of the lens? Air turbulence may be getting moisture on the lens even though it it is facing rearward.

Here is a suggestion: I spoke to my neighbor whom was polishing his truck and asked what he was using. "ReJex" was the reply. He went on to say that he uses this on his truck glass, boat windshield (plastic) and his fiberglass boat (used on salt water) as-well. I tried it and it does a phenomenal job of sheeting water off both glass and plastic windshields. A coating of this on the camera lenses may solve your problem. Besides sheeting off, it does not fog, does not leave a visible film, and does not damage the surface of the application. It is not cheap, but it may be worth a try.A little goes a long way.

http://www.amazon.com/Corrosion-X-61...ive+car+polish
__________________

__________________
PenJoe is offline   Reply With Quote
Old 11-28-2015, 02:43 PM   #22
Senior Member
 
Boso's Avatar
 
Join Date: Dec 2014
Posts: 1,198
No I don't think so you can dry and no change have tried wax pure silicone spray then polish nothing seems to work but time it always get worse if a constant rain have had to clear after a few days and then re fog as I drove with no rain then clear up after 4-5 hrs of driving
__________________

__________________
i2015 sunseeker 3050s. 2007 saturn aura
Boso is offline   Reply With Quote
Old 11-28-2015, 02:45 PM   #23
Senior Member
 
Boso's Avatar
 
Join Date: Dec 2014
Posts: 1,198
My thought until the first cameras were replaced was moisture entering the lens itself but not after the same problem on second set of cameras
__________________
i2015 sunseeker 3050s. 2007 saturn aura
Boso is offline   Reply With Quote
Old 12-01-2015, 09:47 PM   #24
Senior Member
 
Sagecoachdriver's Avatar
 
Join Date: Jun 2015
Location: Southern California
Posts: 1,466
Thanks Penjoe!

PenJoe, you were right, the cable was the problem with the incompatible wiring. Retested it today with the old cable and it works. There are actually two cables connected together and the dealer received one very long one from FR.
Not sure if the dealer is getting a new set or installing the old ones with the splices.
__________________
2004 Winnebago Minnie 22e(went to a nice family Oct 3, 2015)
2016 Forester 2701DS (Aug 31, 2015)
2017 Camping 10 trips 32 nights
Sagecoachdriver is offline   Reply With Quote
Old 12-02-2015, 08:35 AM   #25
Senior Member
 
Join Date: Oct 2015
Location: Wisconsin/Florida
Posts: 793
Happy it worked out for you.
__________________

__________________
PenJoe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:54 PM.