Reply
 
Thread Tools Display Modes
Old 03-18-2015, 11:00 AM   #11
Senior Member
 
Ashley's Avatar
 
Join Date: Oct 2014
Location: North Central Florida
Posts: 116
Quote:
Originally Posted by suscamper View Post
Yes. Cranks not weakly but doesn't start up . Have have battery charger. Anti theft not on. This RV only has 600 mi on it.
Sounds like it is time for a call to the Dealer, either RV or GM, one or the other. Seems like you have covered what should be on you as far as possible drained or weak battery. I would let them deal with it now since it is a brand new unit.
__________________

__________________
------------------------------------------------------------
2008 Dodge Ram 3500 MegaCab 6.7 Cummins
4x4, 4.10 Gears, 68RFE Trans
2012 Primetime Lacrosse 318 BHS
Ashley is offline   Reply With Quote
Old 03-18-2015, 11:29 AM   #12
Senior Member
 
Pixelbum1's Avatar
 
Join Date: Jan 2015
Location: SW Ohio
Posts: 196
Well then, time to buy a new one! Kidding...kidding. We assume this is a gas engine on a Chev chassis and not a diesel? Just sayin...
__________________

__________________
Pixelbum1 is offline   Reply With Quote
Old 03-18-2015, 12:06 PM   #13
Member
 
Join Date: Sep 2014
Posts: 53
They are coming to toe it to the shop. We give up. Not a good way to start
__________________
suscamper is offline   Reply With Quote
Old 03-18-2015, 12:08 PM   #14
Senior Member
 
Join Date: Dec 2014
Posts: 175
Don't be discouraged. It will be fixed for free and then you will be good to go. New mechanical issues happen.
__________________
ActionJackson is offline   Reply With Quote
Old 03-18-2015, 12:33 PM   #15
Senior Member
 
B and B's Avatar
 
Join Date: Jun 2013
Location: Wilmot Twp, Ontario, Canada
Posts: 8,604
These chassis must have a fuel shutoff switch, just like a truck. In case of an accident. Possibly it has been tripped.
__________________
B and B is online now   Reply With Quote
Old 03-18-2015, 12:44 PM   #16
Junior Member
 
Join Date: Jan 2015
Location: Portland On
Posts: 17
how old is the gas it might have sat in the tank over winter and could have water in gas if stabilizer was not used
__________________
backwoodsbob is offline   Reply With Quote
Old 03-18-2015, 08:37 PM   #17
Senior Member
 
Garrette's Avatar
 
Join Date: Mar 2013
Posts: 956
Please post the fix to your problem. Helps all learn.


Sent from my iPad using Forest River Forums
__________________
Garrette is offline   Reply With Quote
Old 03-21-2015, 12:37 AM   #18
Senior Member
 
tmhyer's Avatar
 
Join Date: Apr 2014
Posts: 299
I think they said what the issue is. It's on a Chevy chassis
__________________
tmhyer is offline   Reply With Quote
Old 03-21-2015, 08:51 AM   #19
Senior Member
 
Join Date: Mar 2013
Posts: 133
Quote:
Originally Posted by tmhyer View Post
I think they said what the issue is. It's on a Chevy chassis

A lot less issues on the Chevy chassis than the Ford Chassis!!


Sent from my iPhone using Forest River Forums
__________________
markangie24 is offline   Reply With Quote
Old 03-21-2015, 11:41 AM   #20
Senior Member
 
Pixelbum1's Avatar
 
Join Date: Jan 2015
Location: SW Ohio
Posts: 196
Quote:
Originally Posted by backwoodsbob View Post
how old is the gas it might have sat in the tank over winter and could have water in gas if stabilizer was not used
I think you NAILED it BWB! Even "new" can succumb to ignored tricks-of-the-trade, right? Hopefully it was as simple as this fix.
__________________

__________________
Pixelbum1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:58 AM.