Reply
 
Thread Tools Display Modes
Old 08-26-2011, 11:24 PM   #1
Junior Member
 
danyliz's Avatar
 
Join Date: Aug 2011
Posts: 18
Piezo electric ignitor

Our stove top was working just fine until this trip...

Having trouble getting stove to light using the piezo electric ignitor on all 3 stove top burners. We have followed the trouble shooting instructions on the manual; bleeding, etc. Using matches to light burners are ok; but our RV is brand new. Any tips out there?
__________________

__________________
danyliz is offline   Reply With Quote
Old 08-26-2011, 11:36 PM   #2
Senior Member
 
Join Date: Feb 2011
Location: Regina, Sask.
Posts: 123
You getting propane to the burners? Maybe the regulator is set to a propane tank that isn't turned on.
__________________

__________________
Ken & Janet
'07.5 GMC 2500 D/A CC/SB
'09 SABRE 31RETS-6
wingriders is offline   Reply With Quote
Old 08-26-2011, 11:48 PM   #3
Junior Member
 
danyliz's Avatar
 
Join Date: Aug 2011
Posts: 18
Propane is on... Stove burners work when I light it with match. Regulator?
__________________
danyliz is offline   Reply With Quote
Old 08-27-2011, 12:24 AM   #4
Senior Member
 
jimh's Avatar
 
Join Date: Jul 2010
Location: Lake Charles, La.
Posts: 1,531
lift the top on the stove and watch the spark ignitors while u turn the handle. see if they are sparking.
i don't know if there is only one or three ignitors. either way see if they appear to still b in place.

outside of a visual check for an ignitor out of place, i have nothing to offer.
believe ur ok on the gas if u can light the burner with a match.
__________________
jimh is offline   Reply With Quote
Old 08-27-2011, 12:54 AM   #5
Junior Member
 
danyliz's Avatar
 
Join Date: Aug 2011
Posts: 18
Thanks for the info. No spark from ignitors Anyone else have any tips?
__________________
danyliz is offline   Reply With Quote
Old 08-27-2011, 08:16 AM   #6
Lottery Non-Winner
 
Ovair's Avatar
 
Join Date: Jul 2011
Posts: 437
Does the piezo igniter make the popping (release) sound? Or is it relatively quiet? It should be louder than snapping your fingers. Is the wire attached firmly and clean contact? Check to make sure there is no plastic sheeting between piezo module and mounting surface.
If.... there's no material interfering with the mating, and the wire is attached well, and it makes a good popping sound, I can only suggest that the piezo itself is bad.
__________________

2011 Georgetown 337
2009 HD FLHTCU
2007 HD FXSTC
Ovair is offline   Reply With Quote
Old 08-28-2011, 08:52 AM   #7
Senior Member
 
jimh's Avatar
 
Join Date: Jul 2010
Location: Lake Charles, La.
Posts: 1,531
the knob rotates a full 360 deg. if ur going full circle...past the resistance until a loud pop is heard... and everything is in place, may need replacing.
__________________
jimh is offline   Reply With Quote
Old 08-28-2011, 02:59 PM   #8
Lottery Non-Winner
 
Ovair's Avatar
 
Join Date: Jul 2011
Posts: 437
That's a good point Jimh. The knob goes all the way around. Might have to twist it hard to make it "go".
__________________

2011 Georgetown 337
2009 HD FLHTCU
2007 HD FXSTC
Ovair is offline   Reply With Quote
Old 08-28-2011, 04:23 PM   #9
Senior Member
 
Nigels's Avatar
 
Join Date: Jul 2010
Location: BC Canada
Posts: 632
One time we had no spark at two of the burners , after taking the stove top off, (it just lifts off with a good pull upwards) I found two of the wires had come off the contacts at the back of the knob.

Sometimes they don't want to light and we have to turn the knob 3 or four times, like 3x360deg to get it to light.

One thing though I notice at high altitudes it is harder to light.

The oven is another story
__________________

__________________
Nigel & Bev
Brit Driver & Canadian Naviguesser

2011 Rockwood Signature Ultra Lite 8280ws
2011 Dodge Ram 3500 4x4 Diesel
http://www.algarvevillaforrent.com
Nigels is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:38 AM.