Thread Tools Display Modes
Old 01-14-2015, 06:40 PM   #11
Senior Member
Join Date: Jul 2013
Posts: 138
We had to take our Avenger back 2 times. because we could get the tv to do anything. the 1st time they had to replace the antennae because it wouldn't unfold all the way, the 2nd time to connect the antennae into the entertainment center and the tv and DVD player together. it wasn't attached together when we bought it.
not sure if was dealer error or Factory install gone wrong

ValMelton is offline   Reply With Quote
Old 01-14-2015, 08:42 PM   #12
Junior Member
Join Date: Jan 2015
Posts: 13
It looks like we will have someone take a look at it. Thank you for the help. Greatly appreciated! I will also look into the Magnadyne manual but I suspect that something was never hooked up.

joyfulmajoya is offline   Reply With Quote
Old 01-14-2015, 09:44 PM   #13
Join Date: Dec 2013
Location: Kansas City
Posts: 54
Did you set the emergency brake?

Sent from my iPad using Forest River Forums
coldj is offline   Reply With Quote
Old 01-15-2015, 01:28 PM   #14
bclemens's Avatar
Join Date: May 2011
Location: Elkhart, IN
Posts: 5,056
Originally Posted by coldj View Post
Did you set the emergency brake?

Sent from my iPad using Forest River Forums
Won't matter. the emergency brake only locks out the dash screen...not the rear output.

I'm guessing
A. something is not hooked up or
B. This unit has a switch box and it was not wired directly. I have a thread on this as well. If you look at the back of the TV you should see a Red/White?yellow cable INOT the AV1 hook up. (there is also an audio out, but thats another topic). If those are not there, then you may have a switch box. Those cables will go into the switch box and then to the TV via coax. In that case you have to change to "scan for channels" via "cable". A direct connection to AV1 is always better for image quality etc.
PLEASE do not send questions via Private Message, my inbox fills up too quickly. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only (VIN, Contact info or things you do not want the public to see).
bclemens is offline   Reply With Quote
Old 01-27-2015, 10:47 PM   #15
Junior Member
Join Date: Jan 2015
Posts: 13
We do have the red, white and yellow cables hooked to the back of TV. They appear to lead into the cabinet above the entrance door.

joyfulmajoya is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:47 AM.