Reply
 
Thread Tools Display Modes
Old 06-29-2014, 10:18 AM   #1
Member
 
prayers1's Avatar
 
Join Date: May 2013
Posts: 55
1998 P30 Chassis Auto Park Brake HELP!

I have a 1998 Georgetown 34ft Motorhome on a Chevy P30 Chassis.
The Auto Park Brake is not holding the coach. If I put it in Park, it will still roll.

When ever I put it into Park or Drive, I can hear it cycling, but it doesn't hold back the Coach when in Park.

On a slight decline of decline the Coach will roll.

NEED HELP!!

How do I diagnosis this problem?
__________________

__________________
prayers1 is offline   Reply With Quote
Old 06-29-2014, 10:55 AM   #2
Senior Member
 
Sbryant's Avatar
 
Join Date: Nov 2013
Location: Quitman MS
Posts: 357
I had this prob. Under the coach there is a hydraulic reservoir. If it is empty fill it with any hydraulic fluid. Mine became empty because the oil pressure valve was leaking. You can buy a new one at any Chevy dealership.
__________________

__________________
Sbryant is offline   Reply With Quote
Old 06-29-2014, 11:40 AM   #3
Member
 
prayers1's Avatar
 
Join Date: May 2013
Posts: 55
Thank you for the reply.
The reservoir is full. Any other ideals?
__________________
prayers1 is offline   Reply With Quote
Old 06-29-2014, 01:20 PM   #4
Senior Member
 
Sbryant's Avatar
 
Join Date: Nov 2013
Location: Quitman MS
Posts: 357
It works on 12 volt electricity - check to see if it is getting power to it - it may be a blown fuse or a tripped circuit breaker - I don't where they are. If there is no power to it, you could run another power wire to it.
__________________
Sbryant is offline   Reply With Quote
Old 06-29-2014, 01:46 PM   #5
Member
 
prayers1's Avatar
 
Join Date: May 2013
Posts: 55
My version is hydraulic, off of the power steering pump.
When ever I put the Coach in gear or Park I can hear the Pump cycle. I can also pull the knob and here it cycle. The Reservoir is full and I found no leaks.


Problem- Coach rolls in Park

I did the RGS Test,
In Park, Knob pushed in - auto park lite stays on.
Put in gear, lite goes off. (Can hear pump cycle a few sec on goes off).
Put back in gear and hear something engaging.
Put in gear, apply brakes, pull knob - lite goes on and hear something engaging, push knob in and hear the pump cycling.

Could it be the Auto Park Brake drum needs adjusting. Doesn't seem so with 44000 miles, but maybe?
How do I adjust them and which way to turn the adjuster??

Any other thoughts on what to do to diagnosis this problem.
__________________
prayers1 is offline   Reply With Quote
Old 06-29-2014, 02:14 PM   #6
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by prayers1 View Post
My version is hydraulic, off of the power steering pump.
When ever I put the Coach in gear or Park I can hear the Pump cycle. I can also pull the knob and here it cycle. The Reservoir is full and I found no leaks.

Problem- Coach rolls in Park

I did the RGS Test,
In Park, Knob pushed in - auto park lite stays on.
Put in gear, lite goes off. (Can hear pump cycle a few sec on goes off).
Put back in gear and hear something engaging.
Put in gear, apply brakes, pull knob - lite goes on and hear something engaging, push knob in and hear the pump cycling.

Could it be the Auto Park Brake drum needs adjusting. Doesn't seem so with 44000 miles, but maybe?
How do I adjust them and which way to turn the adjuster??

Any other thoughts on what to do to diagnosis this problem.
I drove away 2X with that same setup. Smoked the brake, had to be renewed.
__________________
VinceU is offline   Reply With Quote
Old 06-29-2014, 02:27 PM   #7
Senior Member
 
Sbryant's Avatar
 
Join Date: Nov 2013
Location: Quitman MS
Posts: 357
I had to adjust my brake, it had worn down. You just have to adjust it in one direction to see if that's the right way. If not, adjust the other way. If you can wiggle the drum side to side, it needs adjusting. It would help to raise one rear wheel off the ground with the jacks.
__________________

__________________
Sbryant is offline   Reply With Quote
Reply

Tags
brakes

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:51 PM.