Reply
 
Thread Tools Display Modes
Old 06-24-2013, 05:23 PM   #1
Full Time RV'rs.
 
Nepas's Avatar
 
Join Date: Aug 2012
Location: Fort Pierce
Posts: 91
AC Unit

Have a new 2012 Georgetown and the front AC unit dont seem to be cooling. Just fan. Rear AC works fine.

Any suggestions.
__________________

__________________
Nepas is offline   Reply With Quote
Old 06-24-2013, 05:25 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Do you have dual zone thermostat or thermostat for each unit? Also what is manufacturer of thermostat.
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Old 06-24-2013, 05:34 PM   #3
Full Time RV'rs.
 
Nepas's Avatar
 
Join Date: Aug 2012
Location: Fort Pierce
Posts: 91
Quote:
Originally Posted by fonzie View Post
Do you have dual zone thermostat or thermostat for each unit? Also what is manufacturer of thermostat.

Have digital thermo, one for each AC. Dometic

__________________
Nepas is offline   Reply With Quote
Old 06-24-2013, 06:00 PM   #4
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Are your thermostats set to "auto"....here is manual just in case you need it and troubleshooting....
Attached Files
File Type: pdf Dometic Thermostat- Single Zone Digital.pdf (1.40 MB, 12 views)
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Old 06-24-2013, 06:03 PM   #5
Full Time RV'rs.
 
Nepas's Avatar
 
Join Date: Aug 2012
Location: Fort Pierce
Posts: 91
Quote:
Originally Posted by fonzie View Post
Are your thermostats set to "auto"....here is manual just in case you need it and troubleshooting....
Yes they are on auto.
__________________
Nepas is offline   Reply With Quote
Old 06-25-2013, 03:17 PM   #6
Full Time RV'rs.
 
Nepas's Avatar
 
Join Date: Aug 2012
Location: Fort Pierce
Posts: 91
Service tech came out. Bad relay switch. Should be fixed by friday.

Thanks for the help
__________________
Nepas is offline   Reply With Quote
Old 06-28-2013, 05:21 PM   #7
Full Time RV'rs.
 
Nepas's Avatar
 
Join Date: Aug 2012
Location: Fort Pierce
Posts: 91
Service tech came out. Checked unit. Called Dometic and they told him bad relay.

Ok

New relay and thermostat replaced yesterday and still no work.

He called Dometic back, jumped the compressor and still nothing.

Dometic said we will ship you a new AC to install for the customer.

Not even a year old yet
__________________

__________________
Nepas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:46 PM.