Reply
 
Thread Tools Display Modes
Old 02-15-2015, 06:36 PM   #1
Member
 
GABoy's Avatar
 
Join Date: Apr 2014
Posts: 247
Auto transfer switch problem?

Camping this weekend. Hooked up on two separate sites on two days. When initially plugged in, our surge protector showed proper voltage and lines wired correctly during its time delay count down to energize system. At end of countdown the transfer switch made its usual loud clunk to engage but didn't and surge protector reset its count down for redo. After three attempts the transfer switch finally engaged properly to allow power through. It did this on both sites both days. Is this a transfer switch problem? Anyone have this happen?
Thanks for input!



Sent from my iPhone using Forest River Forums
__________________

__________________
2014 Georgetown 351DS
Chevy Colorado Crew
GABoy is offline   Reply With Quote
Old 02-15-2015, 06:43 PM   #2
Senior Member
 
Join Date: Feb 2012
Posts: 1,101
So you have a transfer switch that goes from the generator to wired? If you have a larger load on when this happens you might have a surge that is causing the line voltage to drop so the under voltage is liking in and the transfer switch resets.
__________________
Ontario

Vibe 6501
1 Prospector Canoe
2 Mtn. Bikes
4 Hiking Boots
Happy Vibe is offline   Reply With Quote
Reply

Tags
transfer switch

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:51 PM.