Reply
 
Thread Tools Display Modes
Old 06-04-2011, 01:19 PM   #1
Senior Member
 
dashonthedash's Avatar
 
Join Date: Oct 2010
Posts: 202
Awning problem

Anyone else have this problem? I have the standard A&E awning on my new Georgetown. I had an A&E awning for about 17 years on my old coach, and never had a mechanical problem of any kind, other than a realignment or two. Last weekend, third trip out with the new coach, I was adjusting the awning when the plastic rivet that "locks" the handle to the arm broke. An examination of the piece showed that it is flimsier than the parts in most Chinese toys. While at the dealer for warranty repairs, they opened the awning to take a picture, and the same piece on the other arm broke. The dealer has ordered two new arms for the awning, and promised they will be of a higher quality. This certainly seems a bit cheap and flimsy for a normally quality product.
__________________

__________________

Gary Shapiro, 2011 Georgetown 29' Class A
Dash, Molly & Lily - now at the Bridge and forever in my heart
Shadow - 4-year-old Greyhound
Hannah - 1 1/2-year-old GSD rescue
dashonthedash is offline   Reply With Quote
Old 06-04-2011, 10:45 PM   #2
Member
 
Join Date: Apr 2011
Posts: 33
Is your awning manual?? If not, I saw the issue last weekend with another georgetown camper. He said that the dealer had to replace knobs.
__________________

__________________
Tbeasley77 is offline   Reply With Quote
Old 06-04-2011, 11:34 PM   #3
Senior Member
 
dashonthedash's Avatar
 
Join Date: Oct 2010
Posts: 202
It is a manual awning.
__________________

Gary Shapiro, 2011 Georgetown 29' Class A
Dash, Molly & Lily - now at the Bridge and forever in my heart
Shadow - 4-year-old Greyhound
Hannah - 1 1/2-year-old GSD rescue
dashonthedash is offline   Reply With Quote
Old 07-08-2011, 08:47 AM   #4
Member
 
Join Date: Jun 2011
Location: Delray Beach, FL
Posts: 34
Not sure if it's the same problem but on my new Georgetown 378 (1800 miles on it) the awning motor went while awning extended. I was able to get it back in but had to take it in to an RV repair station to have it reseated so I could get back home (600 miles to go). tech said the motor was not powerful enough. It worked probably 10/15 times then nothing.

Jim
__________________
Homejames is offline   Reply With Quote
Reply

Tags
awning

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:54 PM.