Reply
 
Thread Tools Display Modes
Old 07-31-2013, 12:42 PM   #1
Senior Member
 
armye7's Avatar
 
Join Date: Jan 2012
Posts: 264
Back up camera

Went down last night to get our 2012 378 packed for Goshen to head to the big rally and my monitor is not working it has power but no picture on monitor backing or turning. Any clues I tried to troubleshoot but no luck
__________________

__________________
armye7 is offline   Reply With Quote
Old 07-31-2013, 12:56 PM   #2
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
Did you try turning the Contrast or Brightness Knobs? Day/Night Button? If turned down all the way at least on my black and white monitor there's only a blank screen.
__________________

__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is offline   Reply With Quote
Old 07-31-2013, 01:07 PM   #3
Senior Member
 
armye7's Avatar
 
Join Date: Jan 2012
Posts: 264
On the new monitors there is a menu button to adjust contrast but screen is so dark can't see anything to adjust.
__________________
armye7 is offline   Reply With Quote
Old 07-31-2013, 01:19 PM   #4
Senior Member
 
CSMRetired's Avatar
 
Join Date: May 2013
Location: N. Central Texas
Posts: 1,102
Had the same issue

Unless the adjustment worked for you. On ours (351 DS) we had to have a the right side camera replaced.....seems to have fixed the problem IAW the dealership, we pick it up Saturday, so we'll see
__________________

'Pa Pa's Palace'

2014 Sportscoach Crosscountry 405FK
2015 Jeep Grand Cherokee Overland
CSMRetired is offline   Reply With Quote
Old 07-31-2013, 01:24 PM   #5
Senior Member
 
armye7's Avatar
 
Join Date: Jan 2012
Posts: 264
I hope to get forest river to take a look at it at the rally
__________________
armye7 is offline   Reply With Quote
Old 07-31-2013, 01:58 PM   #6
Senior Member
 
CSMRetired's Avatar
 
Join Date: May 2013
Location: N. Central Texas
Posts: 1,102
Good luck on your trip, hope it's an easy fix
__________________

'Pa Pa's Palace'

2014 Sportscoach Crosscountry 405FK
2015 Jeep Grand Cherokee Overland
CSMRetired is offline   Reply With Quote
Old 07-31-2013, 04:33 PM   #7
Senior Member
 
Join Date: Sep 2012
Posts: 143
My 2013 350 does the same from time to time. I have it on the list for FR to replace. It seemed to be a timing issue. If I turn the key on to start the engine, I leave on Accessory until the screen comes on. Then I start the engine. If I do that sequence too quickly....no picture on the screen. FR said this is a problem they have seen before and it's a Clarion software problem that newer unit have corrected.
__________________
MGOBlue is offline   Reply With Quote
Old 07-31-2013, 05:06 PM   #8
Senior Member
 
Join Date: Jul 2013
Location: Roxboro, NC
Posts: 267
If you want to hold off powering up the screen while your are starting you engine you can install a one shot delay relay inline with the screen. This will hold the screen off until the timer delay has counted down. You can find them at Grainger or other supply houses.
__________________
2007 GMC 2500 Duramax Crew Cab LB
2008 5th Wheel Cardinal 36LE
R Whitlow is offline   Reply With Quote
Old 08-06-2013, 02:13 PM   #9
Senior Member
 
CSMRetired's Avatar
 
Join Date: May 2013
Location: N. Central Texas
Posts: 1,102
Armye7

Did you get your camera fixed?
Got mine back from the dealer (warranty work) they had to replace the right camera.....fixed everything
__________________

'Pa Pa's Palace'

2014 Sportscoach Crosscountry 405FK
2015 Jeep Grand Cherokee Overland
CSMRetired is offline   Reply With Quote
Old 08-07-2013, 08:06 AM   #10
Senior Member
 
armye7's Avatar
 
Join Date: Jan 2012
Posts: 264
They are coming this morning to do all repairs. I will keep you posted. We are at the rally and they have been pretty busy trying to take care of everyone's unit.
__________________

__________________
armye7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:42 PM.