Reply
 
Thread Tools Display Modes
Old 05-17-2014, 06:37 PM   #1
Junior Member
 
jimacamper's Avatar
 
Join Date: Feb 2014
Location: Indianapolis
Posts: 26
Dead '14 GT XL

Got to the GT and and found when I turned on the master kill switch by the door to turn on lights that the pulsed and there was a clicking sound from the battery bank below the steps. I then went to fire up the engine and nothing. Not even lights telling me it couldn't work. Tried the battery boost but the same result. I looked at the battery indicator and it showed one light, pulsing. Then though perhaps the generator. Wouldn't fire up. So I started looking for power and found a regular outlet, plugged in the GT for about 10 min and it turned over without the boosters or any hesitation. Ideas?
__________________

__________________
Georgetown XL 350ts
Past:
LivinLite Quick silver
Coleman 12' Pop up
Jayco X23B
jimacamper is offline   Reply With Quote
Old 05-17-2014, 06:41 PM   #2
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,840
How long has it been sitting?
Battery tender?

Check the water in the batteries.
__________________

__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Old 05-18-2014, 09:17 AM   #3
Senior Member
 
abjb's Avatar
 
Join Date: Dec 2011
Posts: 548
Very unusual for ALL the batteries to discharge at the same time.
Our chassis battery holds a charge MUCH longer than the house batteries, they have a draw on them ALL the time, even with the master switch off.

Sorry but it sounds like a warranty visit is in your future.
let us know how you're doing

ab&jb
__________________
2012 Georgetown 360
SHE wanted "a new motorhome"
abjb is offline   Reply With Quote
Old 05-19-2014, 11:42 AM   #4
Junior Member
 
jimacamper's Avatar
 
Join Date: Feb 2014
Location: Indianapolis
Posts: 26
Yea, Sounds like I'll be in for work. The RV only sat 4 weeks between use.
__________________
Georgetown XL 350ts
Past:
LivinLite Quick silver
Coleman 12' Pop up
Jayco X23B
jimacamper is offline   Reply With Quote
Old 05-21-2014, 03:33 PM   #5
WDK
Senior Member
 
WDK's Avatar
 
Join Date: Dec 2013
Location: San Jacinto
Posts: 255
..:..I would expect your coach batteries to be to low after sitting for a month and if the chassis battery is perhaps a couple of years old or more I would have my doubts about it as well. When you did get it started, did the coach batteries come up or at least a 2 or 3 lights on your battery display panel?

WDK
__________________
WDK is offline   Reply With Quote
Old 05-22-2014, 10:57 AM   #6
Junior Member
 
jimacamper's Avatar
 
Join Date: Feb 2014
Location: Indianapolis
Posts: 26
Coach batteries were just fine. We wondered about a faulty/stuck inverter or converter which could leave the connect between the batteries open.
__________________

__________________
Georgetown XL 350ts
Past:
LivinLite Quick silver
Coleman 12' Pop up
Jayco X23B
jimacamper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:01 AM.