Reply
 
Thread Tools Display Modes
Old 04-18-2010, 09:12 PM   #11
Pilot
 
Join Date: Apr 2010
Location: Caledonia, MI
Posts: 5
We had the same problem with our toilet as well, there is a one year warranty, so we put it back on the dealer and they put a 2 inch straight tube on it which solved the problem, I also put two clamps on it to help. I believe the line was slipping off the fitting at the back of the toilet. Also, started using a pressure gauge on the water inlet to regulate the water pressure. Also, on the hydrualics, I would suggest getting this checked out. I had all fo the hydraulic fluid leak out of the unit after we had used it only one time, the alarm sounded like the jacks were down.

Tim
__________________

__________________
TimF is offline   Reply With Quote
Old 04-20-2010, 03:53 PM   #12
Senior Member
 
Join Date: Mar 2010
Location: SW of NE Arkansas
Posts: 116
I found the cause of the fluid leak, and fixed that just need to add AT fluid. I will be checking the toilet hose next.
__________________

__________________
ArkyGeorgetown330TS is offline   Reply With Quote
Old 04-20-2010, 04:23 PM   #13
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
What was the cause of the AT fluid leak?
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 04-21-2010, 10:31 AM   #14
Senior Member
 
Join Date: Mar 2010
Location: SW of NE Arkansas
Posts: 116
The leak was caused by a plug in the manifold that was used where a hose would normally fit. It was loose from the factory and I used a allen wrench to tighten. No more leak. Sure was worried for a while, it was our first trip out. Now to tackle the potty leak. Thanks for all the info from everyone.
__________________
ArkyGeorgetown330TS is offline   Reply With Quote
Old 04-21-2010, 10:53 AM   #15
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,258
Happy to hear it was nothing big and an easy fix!!!
__________________

__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:15 AM.