Reply
 
Thread Tools Display Modes
Old 08-18-2014, 02:45 PM   #1
Member
 
Join Date: Aug 2014
Posts: 70
Furnace Squeal

Hi all! I'm new to the forum. I just purchased a new 2014 Georgetown XL 377 the end of July. The front furnace has a squeal for 15-20 seconds when the burner kicks on (not the fan). The rear furnace is fine.

I talked to the technician at the dealer and he said that new ones frequently do that the first couple times, but then it goes away. I told him it wasn't going away after at least twenty cycles. He thought it might be air leaks as the metal expands with the heat and suggested trying aluminum tape on seams that are leaking. I did that without success.

Anyone else run into this or have a suggestion before I drive it around a hundred miles to the nearest dealer (not where I bought it) for warranty service?

Thanks
Ron
__________________

__________________
FroggyRon is offline   Reply With Quote
Old 08-18-2014, 03:54 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
How can you be sure it isn't the blower?
The blower is the first thing to come on before the furnace lights. Correct?

TURBS

"SABRE OWNERS UNITED"
__________________

__________________
TURBS is offline   Reply With Quote
Old 08-18-2014, 04:05 PM   #3
Senior Member
 
Join Date: Aug 2014
Posts: 258
I agree with turbo... On my older TT the blower kicked on before the heat...
__________________
2010 Georgetown 300FWSSouth Florida
speedjester is offline   Reply With Quote
Old 08-18-2014, 04:08 PM   #4
Senior Member
 
Join Date: Aug 2014
Posts: 258
I do remember when I changed my water heater... I didn't adjust the flame correctly and it would howl/ squeak ... Tech told me to adjust the flame.. Didn't help but eventually went away...good luck
__________________
2010 Georgetown 300FWSSouth Florida
speedjester is offline   Reply With Quote
Old 08-18-2014, 04:53 PM   #5
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 7,623
Quote:
Originally Posted by FroggyRon View Post
Hi all! I'm new to the forum. I just purchased a new 2014 Georgetown XL 377 the end of July. The front furnace has a squeal for 15-20 seconds when the burner kicks on (not the fan). The rear furnace is fine.

I talked to the technician at the dealer and he said that new ones frequently do that the first couple times, but then it goes away. I told him it wasn't going away after at least twenty cycles. He thought it might be air leaks as the metal expands with the heat and suggested trying aluminum tape on seams that are leaking. I did that without success.

Anyone else run into this or have a suggestion before I drive it around a hundred miles to the nearest dealer (not where I bought it) for warranty service?

Thanks
Ron
What seams? If your heat exchanger is leaking you are letting carbon monoxide in your trailer.
__________________
Rockwood #8289 WS 2012
F250 6.0 / Husky 16k
With 4 point leveling system
Witch Doctor is offline   Reply With Quote
Old 08-18-2014, 05:22 PM   #6
Member
 
Join Date: Aug 2014
Posts: 70
Quote:
Originally Posted by f1100turbo View Post
How can you be sure it isn't the blower?
The blower is the first thing to come on before the furnace lights. Correct?

TURBS

"SABRE OWNERS UNITED"

Hi Turbo. I haven't completely written off the blower. You are correct that the blower comes on first and runs quietly for about 30 seconds before the burner ignites. After the burner ignites and it starts heating up for 10 or 15 seconds, the squeal starts. That's why the technician thought it might be air leakage through the duct work as it heats. It might be the heat is affecting the blower also. Don't know. Thanks for the reply.

Ron
__________________
FroggyRon (Ron)
2014 Forest River Georgetown XL 377
2014 Jeep Cherokee Latitude 4X4 toad
FroggyRon is offline   Reply With Quote
Old 08-18-2014, 05:26 PM   #7
Member
 
Join Date: Aug 2014
Posts: 70
Quote:
Originally Posted by gljurczyk View Post
What seams? If your heat exchanger is leaking you are letting carbon monoxide in your trailer.

The seams that I referred to are around the box that the duct work connects to, not the heat exchanger.

Thanks, appreciate the warning.

Ron
__________________
FroggyRon (Ron)
2014 Forest River Georgetown XL 377
2014 Jeep Cherokee Latitude 4X4 toad
FroggyRon is offline   Reply With Quote
Old 08-18-2014, 05:28 PM   #8
Member
 
Join Date: Aug 2014
Posts: 70
Quote:
Originally Posted by speedjester View Post
I do remember when I changed my water heater... I didn't adjust the flame correctly and it would howl/ squeak ... Tech told me to adjust the flame.. Didn't help but eventually went away...good luck

Thanks Speedjester. I did have one guy tell me that it could be caused by an incorrect gas/air mixture at the burner.

Ron
__________________

__________________
FroggyRon (Ron)
2014 Forest River Georgetown XL 377
2014 Jeep Cherokee Latitude 4X4 toad
FroggyRon is offline   Reply With Quote
Reply

Tags
furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:16 AM.