Reply
 
Thread Tools Display Modes
Old 06-27-2013, 01:47 PM   #1
Senior Member
 
kenandterry's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario, Canada
Posts: 1,323
GENERAC 6500 won't start

Over the winter I exercised our Generac 6500 gas generator religiously every two weeks through the winter. I would run it at least 90 minutes each time, and had it power a couple of electric baseboard heaters, a few appliances and some lighting...........just to put a load on it. It performed flawlessly.

I will add here, the gas tank for the motorhome was full, full, full, and by springtime, still showed full.

One time during the winter, it started as normal, and within a minute of running, it went to a very high engine speed.......higher than I had ever heard. Within 30 seconds, it did NOT correct itself, and I manually shut down the genny. Now it won't run, but it will attempt to start itself as it turns over a couple of times, then flashes the lamp on the start rocker switch 7 times, which is the fault code for "UNDERSPEED" according to the manual.

Any hints?
__________________

__________________

Ken and Terry
2010 Georgetown 330TS being pushed by our
2017 GMC Terrain toad (4 wheels down)
kenandterry is online now   Reply With Quote
Old 06-27-2013, 04:04 PM   #2
Member
 
miked11272's Avatar
 
Join Date: Oct 2011
Posts: 97
I had the same problem it was a bad printed control board. It is about 200.00 and 20 minutes to install. Download a trouble shooting manual and check the 14 wire to the thermal block it was not crimped property I believe it caused the control board to short out. If you need the manual I will try to send it to you.
__________________

__________________
miked11272 is offline   Reply With Quote
Old 07-05-2013, 11:34 AM   #3
Senior Member
 
kenandterry's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario, Canada
Posts: 1,323
The Generac documentation I have really doesn't go in too deep about troubleshooting. Like I mentioned, the flashing light on the start switch flashes 7 times indication "Underspeed".....what ever that means.

Look forward to any documentation you can send my way.

Ken
__________________

Ken and Terry
2010 Georgetown 330TS being pushed by our
2017 GMC Terrain toad (4 wheels down)
kenandterry is online now   Reply With Quote
Old 07-06-2013, 02:53 PM   #4
Member
 
miked11272's Avatar
 
Join Date: Oct 2011
Posts: 97
Exact same thing my generator did flashed 7 times under speed when it actually had to high of rpms . The board is giving a false reading causing the governor to pull down on the throttle. If you go to smokestack.com my post is on there or try to Google generic RV 6500 running at high speed. Good luck let me know how you make out
__________________
miked11272 is offline   Reply With Quote
Old 07-06-2013, 05:51 PM   #5
Member
 
miked11272's Avatar
 
Join Date: Oct 2011
Posts: 97
http://www.smokstak.com/forum/showthread.php?t=111674
This is the link for smokestak.com.
__________________
miked11272 is offline   Reply With Quote
Old 07-06-2013, 06:09 PM   #6
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by kenandterry
The Generac documentation I have really doesn't go in too deep about troubleshooting. Like I mentioned, the flashing light on the start switch flashes 7 times indication "Underspeed".....what ever that means.

Look forward to any documentation you can send my way.

Ken
Underspeed means the. Speed sensor is not feeding the governor control. Could be the control board or speed sensor itself is bad. When either failed, the governor applied full throttle to catch up, obviously it couldn't. The sensor is simply a magnetic pickup.
__________________
VinceU is offline   Reply With Quote
Old 07-06-2013, 06:40 PM   #7
Member
 
miked11272's Avatar
 
Join Date: Oct 2011
Posts: 97
Here is the link. http://gen-parts.com/Manuals/0G7675.pdf
__________________

__________________
miked11272 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:33 PM.