Reply
 
Thread Tools Display Modes
Old 08-28-2015, 03:21 PM   #1
Junior Member
 
Join Date: Feb 2015
Posts: 9
Georgetown 377 Brake/Directional Lights

Directional Lights and Brake Lights work fine so long as you don't do both at the same time. If you have the left or right directional light on and press the brake pedal the directional lights quit working. Can anyone help. 2013 Ford F-Series Super Duty Chassis.
__________________

__________________
beezereece is offline   Reply With Quote
Old 08-28-2015, 10:40 PM   #2
Senior Member
 
abjb's Avatar
 
Join Date: Dec 2011
Posts: 548
Most chassis light (and camera) problems are caused be corroded bulb contacts or a corroded/broken/lose ground.

You need to check EVERY turn/clearance bulb, you'll probably find a few that don't work.
Get some contact cleaner and dielectric grease, clean and grease each bulb. Be careful when working on the ones mounted high it's a long way down.

Here are some links to threads that might help.
blinker won't work
Left turn signal lamp mystery
Problems with cameras
amber clearance lights
__________________

__________________
2012 Georgetown 360
SHE wanted "a new motorhome"
abjb is offline   Reply With Quote
Old 08-29-2015, 07:34 AM   #3
Junior Member
 
Join Date: Feb 2015
Posts: 9
Good info, thanks. All bulbs involving the directional lights/brake lights are working. Did notice I have one clearance light (topside drivers side) out in the front and one clearance light (topside passenger side) out in the rear. Pulled them out but they are hardwired somewhere that I haven't found yet. If i disconnect plug under rear of RV front directional lights will work properly when brake is applied.
__________________
beezereece is offline   Reply With Quote
Old 08-29-2015, 07:39 AM   #4
Senior Member
 
waiter21's Avatar
 
Join Date: Jun 2015
Posts: 627
As JB said, loosing a ground (broken wire) will do very weird things as the current now tries to find a new path to ground.

Question: Did it always do this or was it working ok and just started doing this?

Was any work done on the electrical system recently , i.e. hooking up TOAD lights.
__________________
2001 Coachmen Mirada (Ford F53 6.8L V10) - Toad 2003 Saturn Vue
It won't do MACH 2, but I can get a sandwich and take a pee.
waiter21 is offline   Reply With Quote
Old 08-29-2015, 09:12 AM   #5
Junior Member
 
Join Date: Feb 2015
Posts: 9
I am thinking the issue is a result of Crain RV in Little Rock Arkansas. When we traded our other Georgetown for this one they tore the wiring harness a part to get the lights to work on our TOAD. Guess i had better get up under the rear and do some wire tracing. I just don't remember if I had this issue when I left Little Rock. We were in Huntsville Alabama when I noticed the issue.
__________________
beezereece is offline   Reply With Quote
Old 08-30-2015, 07:05 AM   #6
Senior Member
 
waiter21's Avatar
 
Join Date: Jun 2015
Posts: 627
I think you just found your problem....

ALSO - the problem you described, is this on the MH or the TOAD?

i.e. the MH lights are OK but the TOAD lights do what you described.
__________________

__________________
2001 Coachmen Mirada (Ford F53 6.8L V10) - Toad 2003 Saturn Vue
It won't do MACH 2, but I can get a sandwich and take a pee.
waiter21 is offline   Reply With Quote
Reply

Tags
georgetown, light, brakes

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:19 PM.