Reply
 
Thread Tools Display Modes
Old 04-27-2015, 02:57 PM   #1
Junior Member
 
Join Date: Apr 2015
Posts: 6
Georgetown Antifreeze valve

Can someone help me? We have a 2012 Forrest River Georgetown. Trying to figure out where the anti freeze valve is so we can turn it and have water. The fresh water tank is full and you can here the pump. I read in a very old post that the valve is probably still in the winter position. Just don't know where that is at. Any help will be appreciated. CIndy
__________________

__________________
moosey80203 is offline   Reply With Quote
Old 04-27-2015, 04:30 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
It is usually where your water pump is....find water pump....
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Old 04-27-2015, 04:39 PM   #3
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Take a picture of your water cabinet, I think it is in the lower rh corner.
__________________
OldCoot is offline   Reply With Quote
Old 04-27-2015, 04:49 PM   #4
Member
 
Cyclone Rich's Avatar
 
Join Date: Jan 2014
Location: Ankeny, Iowa
Posts: 59
This attachment has good pictures of the valves for winterizing. Just put them in the opposite positions of the instructions and you should be good to go.
Attached Files
File Type: pdf Winterizing.pdf (1.60 MB, 56 views)
__________________
Rig: 2012 Georgetown 351DS
Family: DW and 3 year old DD and newborn DD
Cyclone Rich is offline   Reply With Quote
Old 04-27-2015, 05:41 PM   #5
Junior Member
 
Join Date: Apr 2015
Posts: 6
We noticed the 2 hoses both had a cap. Only one of ours has a cap. Could that be the problem? Maybe I have to make a run to the RV dealer. The clear cylinder is half full of anti freeze. Do we need to do anything with that? We didn't find a valve to switch on and off by the water pump itself. I'm sure this is such a simple thing if you know what you're doing. We're to ladies who are learning as we go. Really appreciate your help. CIndy
__________________
moosey80203 is offline   Reply With Quote
Old 04-27-2015, 05:43 PM   #6
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Quote:
Originally Posted by moosey80203 View Post
We noticed the 2 hoses both had a cap. Only one of ours has a cap. Could that be the problem? Maybe I have to make a run to the RV dealer. The clear cylinder is half full of anti freeze. Do we need to do anything with that? We didn't find a valve to switch on and off by the water pump itself. I'm sure this is such a simple thing if you know what you're doing. We're to ladies who are learning as we go. Really appreciate your help. CIndy
To see if that is your problem, just put your thumb over the end and try it. If it works you know the problem.
__________________
OldCoot is offline   Reply With Quote
Old 04-27-2015, 05:54 PM   #7
Junior Member
 
Join Date: Apr 2015
Posts: 6
Oh duh? We're going out to try that.
__________________
moosey80203 is offline   Reply With Quote
Old 04-27-2015, 06:07 PM   #8
Junior Member
 
Join Date: Apr 2015
Posts: 6
Thanks to all who helped. You all had a piece of the puzzle. The valve was right there in the lower right hand corner. Put a finger over the plug and had water coming out of the faucet. Now have to go to the RV store. You guys are awesome! Sure I'll have more questions in the future. Cindy
__________________
moosey80203 is offline   Reply With Quote
Old 04-27-2015, 06:23 PM   #9
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Quote:
Originally Posted by moosey80203 View Post
Thanks to all who helped. You all had a piece of the puzzle. The valve was right there in the lower right hand corner. Put a finger over the plug and had water coming out of the faucet. Now have to go to the RV store. You guys are awesome! Sure I'll have more questions in the future. Cindy

Glad to help a little if we did.
__________________
OldCoot is offline   Reply With Quote
Old 04-27-2015, 08:33 PM   #10
Junior Member
 
Join Date: Apr 2015
Posts: 6
Okay, I'm back again. We got the water running. Got rid of all the pink and the toilet flushed just fine. Our water tank is full as is our propane tank. I turned the hot water heater switch on, on the control panel and it fired right up. A minute or so later it went off. Now we can't get it to fire up again. Any suggestions my friends?
__________________

__________________
moosey80203 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:02 PM.