Reply
 
Thread Tools Display Modes
Old 03-30-2016, 08:48 PM   #1
Member
 
RudysWorld's Avatar
 
Join Date: Jan 2012
Location: Collierville, TN
Posts: 452
Georgetown wiper motor

I have a 2011 Georgetown XL 350 and the wipers won't work on intermittent. When turn to intermittent they are constant on. If I use the washers the only way to get to turn off is turn off engine, not the ideal situation. In another thread similar situations were caused by improper ground. Looking at wiper motor there is a ground wire that is hanging loose in the wiper motor area. I am not sure if this should be on the wiper motor and if so where. If anyone has any experience with similar situations I would appreciate information. Thanks
__________________

__________________

Rudy - 10 year old long haired dachshund, RIP
2011 Georgetown 350TS
2013 Chevrolet Equinox toad
RudysWorld is online now   Reply With Quote
Old 03-31-2016, 07:27 AM   #2
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by RudysWorld View Post
I have a 2011 Georgetown XL 350 and the wipers won't work on intermittent. When turn to intermittent they are constant on. If I use the washers the only way to get to turn off is turn off engine, not the ideal situation. In another thread similar situations were caused by improper ground. Looking at wiper motor there is a ground wire that is hanging loose in the wiper motor area. I am not sure if this should be on the wiper motor and if so where. If anyone has any experience with similar situations I would appreciate information. Thanks

Could be the hanging ground wire is replaced by grounding the wiper motor direct to the chassis, no wire required, otherwise it wouldn't work at all. The control mechanism is defective causing lack of control. Should be a Ford chassis part assembly.
__________________

__________________
VinceU is offline   Reply With Quote
Old 03-31-2016, 08:15 AM   #3
Member
 
RudysWorld's Avatar
 
Join Date: Jan 2012
Location: Collierville, TN
Posts: 452
Quote:
Originally Posted by VinceU View Post
Could be the hanging ground wire is replaced by grounding the wiper motor direct to the chassis, no wire required, otherwise it wouldn't work at all. The control mechanism is defective causing lack of control. Should be a Ford chassis part assembly.
That was my assumption, that it was a Ford part, so I brought in to Ford and found out it was a Forest River part. I verified this later, it has a FR part number, manufactured by TruVision. The numbers for TruVision on their website are all disconnected.
__________________

Rudy - 10 year old long haired dachshund, RIP
2011 Georgetown 350TS
2013 Chevrolet Equinox toad
RudysWorld is online now   Reply With Quote
Old 03-31-2016, 09:34 AM   #4
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,359
It is not a Ford part. See link to company that makes them. (AM Equipment)
Maybe you can call and ask them what they think happened.
May also be the wiper module is having an issue.


Reach them by Telephone

7 am and 4 pm, Pacific, Monday – Friday
Telephone: (541) 327-1546
Attached Files
File Type: pdf 705-0020-WI-2P-Installation-Instructions.pdf (355.5 KB, 30 views)
File Type: pdf 801-1085.pdf (4.04 MB, 56 views)
File Type: pdf catalog.pdf (1.27 MB, 62 views)
__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 03-31-2016, 10:30 AM   #5
Member
 
RudysWorld's Avatar
 
Join Date: Jan 2012
Location: Collierville, TN
Posts: 452
Quote:
Originally Posted by Iggy View Post
It is not a Ford part. See link to company that makes them. (AM Equipment)
Maybe you can call and ask them what they think happened.
May also be the wiper module is having an issue.


Reach them by Telephone

7 am and 4 pm, Pacific, Monday Friday
Telephone: (541) 327-1546
Thanks Iggy. I think mine is a different company, it has a TruVision label on it. There is some good information in the files you posted and I will review those.
__________________

Rudy - 10 year old long haired dachshund, RIP
2011 Georgetown 350TS
2013 Chevrolet Equinox toad
RudysWorld is online now   Reply With Quote
Old 04-01-2016, 09:08 PM   #6
Senior Member
 
Join Date: Dec 2012
Location: Hampton Roads, VA
Posts: 322
Most times my wipers will sweep once or twice then stop. I checked out the ground and the power with no problems. I hit the motor with a hammer and it starts and sweeps 2-3 times then stops. Hammer it again and repeat!!!. I tried 28" blades vs 32"--no change.
Solved the problem with rain-X, don't need wipers!!
__________________

__________________
John & Susan, Olivia the dachshund
2011 Georgetown 337DS
2003 Dodge Dakota
Hampton Roads VA
2016 174 Days camping, 2017 66 days
mogman is offline   Reply With Quote
Reply

Tags
georgetown

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:18 PM.