Reply
 
Thread Tools Display Modes
Old 02-21-2012, 08:22 AM   #1
Junior Member
 
Join Date: Feb 2012
Posts: 7
Insrument panel and batt charging total loss

2008 Forest River Georgetown 373. 2007 Ford Class A chassis. Driving down the road total loss of all insturment cluster (except turn signal indication) and eventually Coach (not house) battery went dead. Seem to be interconnected. Talked with Ford 3 times. Repalced Alternator. Didn't fix. Finally wiggled wires looked for ground connection loose ... didn't find anything. Turned on key and all was back. Not sure it's fixed. Anyone else ever experiened this problem?
__________________

__________________
Johnee is offline   Reply With Quote
Old 02-21-2012, 09:17 AM   #2
Senior Member
 
tncruiser's Avatar
 
Join Date: Aug 2010
Location: east tn.
Posts: 416
sound like maybe a bad ignition switch
brianj
__________________

__________________
liven life in east TN and wherever my
2011georgetown280ve, and
2016 fordexplorer and hemi RAM
take us
tncruiser is offline   Reply With Quote
Old 02-21-2012, 10:49 AM   #3
Senior Member
 
nemo45's Avatar
 
Join Date: Aug 2010
Location: Arlington, WI
Posts: 229
Send a message via MSN to nemo45 Send a message via Yahoo to nemo45
Quote:
Originally Posted by Johnee View Post
2008 Forest River Georgetown 373. 2007 Ford Class A chassis. Driving down the road total loss of all insturment cluster (except turn signal indication) and eventually Coach (not house) battery went dead. Seem to be interconnected. Talked with Ford 3 times. Repalced Alternator. Didn't fix. Finally wiggled wires looked for ground connection loose ... didn't find anything. Turned on key and all was back. Not sure it's fixed. Anyone else ever experiened this problem?
I had a simular experience and the problem was the battery connection. It looked ok but when I wiggled it, it was loose and not making a good connection. The bolt going thru the connection was completely corroded thru. Replaced the bolt and cleaned the connection and the battery posts and put post treatment on both of them and haven't had a problem since.
__________________
Don & Carol Niemeyer and Sandy
2006 Gulf Stream Tour Master Diesel Pusher
2011 Chevy Equinox Toad
nemo45 is offline   Reply With Quote
Old 02-22-2012, 08:01 AM   #4
Junior Member
 
Join Date: Feb 2012
Posts: 7
Thanks, the battery connection seemed ok, but I will take bolt out and check / clean / replace as necessary.
__________________
Johnee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:47 PM.