Thread Tools Display Modes
Old 06-20-2010, 04:09 PM   #1
Junior Member
Join Date: Apr 2010
Posts: 25
Interior lights and Water Pump

Can you tell me what, if any interior lights work off the battery? Also should the waterpump work off the battery? I am sure the lights and waterpump as well a the gauge for the tanks etc worked off the battery but that's not the case at least not at the momemt. Any ideas what might be wrong. Everything works when plugged into 120. I checked the battery cables etc. and everything looks ok.

Thanks in advance for any help/suggestions.

blackshadowk1937 is offline   Reply With Quote
Old 06-20-2010, 04:19 PM   #2
Senior Member
Join Date: Feb 2008
Posts: 104
12 Volt power

I have a 2008 Georgetown 335SE. All my interior lights; water pump; furnace' awning (power) all work on 12 volts. When your coach is plugged in; the converter simply converts 110ac to 12 volt. You may notice your interior lights are a little brighter when it;s plugged in and the water pump runs a little faster. If your ligths are not working when it's unplugged from 110 ac; then your battery disconnect switch located in the stairwell is turned off; or your batteries are discharged.. If you only had a blown fuse; only those things on that circuit would be affected (not everything). It rerally sounds like your disconnect switch is engaged. There should be a rocker switch to the left of the stairwell. You should see connect and disconnect. Push it to connect and then try your lights with it unplugged.

Crossfire is offline   Reply With Quote
Old 06-20-2010, 04:24 PM   #3
Senior Member
NWJeeper's Avatar
Join Date: Aug 2008
Location: Enumclaw, WA
Posts: 2,617
Well covered by Crossfire. Everything in your rig except for the microwave, air conditioner and your entertainment systems work on 12volts.

X2 here on the battery disconnect being turned off.
"I can fix it, and if I can't fix it, I can fix it so no one can fix it!"
Ed & Wendy
2009 Georgetown 378TS | 1998 Jeep Wrangler | 1998 Skeeter ZX202C
Nights camped in 2009: 53 | Nights camped in 2010: 55
NWJeeper is offline   Reply With Quote
Old 06-20-2010, 06:05 PM   #4
Senior Member
Join Date: Mar 2008
Location: Jacksonville Florida
Posts: 1,263
My entertainment system works on 12v, as well! Concertone ZX600, and 22" Venturer HDTV, surround sound system, too. ONLY micro. and AC not functional on 12v. Randy
/SIGPIC]'08 V-lite Flagstaff 30WRLS
'06 Ram 1500 QC hemi Reese dual cam sway control,
K&N series 77 intake, Hellwig helper spgs. LT tires,
Flowmaster "true duals", 380 h.p., Bilstein shocks
08flagvlite is offline   Reply With Quote
Old 06-20-2010, 07:35 PM   #5
Junior Member
Join Date: Apr 2010
Posts: 25
Thanks alot Crossfire - you were correct, somehow we must have touched/hit the disconnect switch. This is our first motorhome have had it for about a month and are still learning. It's people like you that make this an excellent forum for learners like me. Thanks again. Have a Great Day.
blackshadowk1937 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:58 AM.