Reply
 
Thread Tools Display Modes
Old 04-29-2014, 01:40 PM   #1
Wildland Firefighter
 
Join Date: Jul 2013
Location: California
Posts: 79
Unhappy Jensen pop up screen

On our 09 GT 357QS, The Jensen radio with the pop up screen for the rear and side cameras won't come out. I never heard anything crack or break. Stopped working half way thru our last 3 day trip a few months ago. Got in the other day to prep it for a trip in a couple weeks and played around with it for a minute and it came out and went back in. Never to happen again. I called Jensen and they don't have any parts for it, Won't work on it, and their replacement for it is bigger so it won't fit the exsisting hole and you have to cut and adapt your wires to it. Soooo... my question is has anyone replaced this thing with something else that still uses all the cameras? And what did you get? Thanks for any input. Also, my Lippert steps broke.. Same story there.
__________________

__________________
Gordon and Dawn is offline   Reply With Quote
Old 04-29-2014, 01:51 PM   #2
Senior Member
 
Join Date: Sep 2013
Location: Gahanna, OH
Posts: 1,414
Post a picture of the radio. Maybe someone can give you an idea. For your steps, recommend ordering the Kwikees if they cannot be repaired.
__________________

__________________
2014 Georgetown 351DS
-TruCenter -Front/Rear CHF -Hellwig Links -Tiger Trak -Ran McNally GPS -ScanGauge -Truck Systems TPMS -5 Star Tune
alparmer is offline   Reply With Quote
Old 04-29-2014, 03:56 PM   #3
Member
 
DanielJ's Avatar
 
Join Date: Jan 2013
Posts: 58
I believe that I have that radio in my Berkshire. Jensen vr-187. I had the same issue a couple of times. Try the reset button. It's the tiny little button that you need to push with a ball point pen or paper clip end. That did the trick for me.
__________________
2008 Berkshire 390TS
DanielJ is offline   Reply With Quote
Old 04-29-2014, 11:46 PM   #4
Wildland Firefighter
 
Join Date: Jul 2013
Location: California
Posts: 79
Jensen pop up screen

Hey... Thank you alparmer.. I'll be diddling with it again in a few days and will do the picture. Great idea. I usually think like that too but frustration got the best of me this time. And thank you Danielj.. I didn't even know about the reset button at all. Now all I have to do is go hunt down a paperclip. Easy-peezie. I'll keep you posted.
__________________
Gordon and Dawn is offline   Reply With Quote
Old 04-30-2014, 11:07 AM   #5
Member
 
DanielJ's Avatar
 
Join Date: Jan 2013
Posts: 58
When my screen refused to deploy, I called Jensen and was given the same story. The tech person said try the reset - if that didn't work the only remedy was to replace the unit with the new version. I was glad that the reset worked!
__________________
2008 Berkshire 390TS
DanielJ is offline   Reply With Quote
Reply

Tags
pop up

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:29 AM.