Reply
 
Thread Tools Display Modes
Old 03-02-2016, 09:49 PM   #11
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by DuncanM View Post
I have the same MH model and year. Had same problem and have posted about it on here. Do a search and you should find it. There is a recall on the wiring harness. To get the jacks to work until you can get the harness replaced, pull the black and white 2 wire plug out of the side of the motor. Then you can cycle the motor to retract all jacks
.
Quote:
Originally Posted by Pauline View Post
Thanks VinceU, Would I be able to drive MH if I can't fix the problem. (if I disconnect the battery to the pump). I may have to have someone else repair this. Does replacing the switch sound like the right thing to do?
If you search for a thread called Hydraulic horrors dtd. 5/8/12 posts 1-11 all history and repair are outlined with photos of the failed parts are displayed. It was complex then but others have had the same problem.
__________________

__________________
VinceU is offline   Reply With Quote
Old 03-03-2016, 07:06 AM   #12
Junior Member
 
Join Date: Jun 2013
Location: Pennsylvania
Posts: 15
Thanks all for your help. It may be a few days before I can get to it. But Thanks all the same.
__________________

__________________
Pauline is offline   Reply With Quote
Old 03-03-2016, 11:41 AM   #13
Member
 
Join Date: Jan 2014
Posts: 97
I have a 2014 351. I can't find that previous post about the jacks recall. Can someone post a link or something if they find it?
__________________
Preadus is offline   Reply With Quote
Old 03-03-2016, 12:41 PM   #14
Member
 
Starboard's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 69
It's the wiring harness, there's a recall. You need to contact LCI and they'll tell you how to manually raise them and then will ship you a new harness. Takes 30 mins to replace it, it's not really a big deal.
__________________

__________________
Starboard is offline   Reply With Quote
Reply

Tags
leveling

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:35 PM.