Reply
 
Thread Tools Display Modes
Old 08-14-2015, 09:45 PM   #1
Senior Member
 
Krazymace's Avatar
 
Join Date: Nov 2013
Location: Sunriver, Oregon
Posts: 502
Lost Running Lights to Toad

I have lost my running lights to my toad. Signal and brake lights are fine. I have no running light power to the MH plug. Checked upstream of plug and have no power. Assume I blew a fuse, but not sure where it is. Tried to open the Power Distribution box under hood, but could not figure out how to get the darn cover off. Any suggestions or solutions on how to get the darn cover off and solutions to my running light issue would be appreciated.


Sent from my iPad using Forest River Forums
__________________

__________________
Krazymace is offline   Reply With Quote
Old 08-14-2015, 10:50 PM   #2
Senior Member
 
Join Date: May 2013
Location: Whitehouse, Texas
Posts: 692
The power box is not easy to take off. I don't remember how I did it but it took some time and I thought I was going to break it.
Keep trying it does snap off.
__________________

__________________
2013 Georgetown XL 378
2008 Honda CR-V
wrapperman is online now   Reply With Quote
Old 08-15-2015, 12:19 AM   #3
Senior Member
 
Krazymace's Avatar
 
Join Date: Nov 2013
Location: Sunriver, Oregon
Posts: 502
Do you know if the running light fuse is there?


Sent from my iPad using Forest River Forums
__________________
Krazymace is offline   Reply With Quote
Old 08-15-2015, 09:35 PM   #4
Senior Member
 
Krazymace's Avatar
 
Join Date: Nov 2013
Location: Sunriver, Oregon
Posts: 502
Finally figured it out. There's a little catch on lower right corner. Got it open. Fuse #15 blown. Replaced and solved my running light problem.


Sent from my iPhone using Forest River Forums
__________________
Krazymace is offline   Reply With Quote
Old 08-16-2015, 01:34 PM   #5
Senior Member
 
Join Date: May 2013
Location: Whitehouse, Texas
Posts: 692
Great
__________________
2013 Georgetown XL 378
2008 Honda CR-V
wrapperman is online now   Reply With Quote
Reply

Tags
light, toad

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:13 PM.