Reply
 
Thread Tools Display Modes
Old 08-29-2013, 06:30 PM   #1
Member
 
Join Date: Sep 2012
Posts: 90
Lots of hydraulic fluid leaks at manifold

The hydraulic slide and leveling jacks on my 2010 378 is leaking again. Last year the leaks were at the electric motor. I had them eplace that with new one that had an o-ring at the drive end. Now I have lots of leaks where the fittings are on the manifolds for each hydraulic line. The lines themselves do not appear to be leaking. There was about a pint or two on my concrete pad. Anyone had the whole thing replaced for same problem?
__________________

__________________
MattM is offline   Reply With Quote
Old 08-30-2013, 11:38 PM   #2
Senior Member
 
Join Date: May 2012
Posts: 513
The fittings on my 2011 327 aren't leaking but I recently had some discussions with a Lippert repair center technician about the condition of the hose fittings. THe hydraulic distribution block is an aluminum casting and doesn't rust. The hose fittings are steel and subject to rusting. All of my hose fittings are badly rusted after just over two years of use.

Lippert initially offered to replace the fittings but when the tech examined them, he discovered that the hoses were not Lippert but were ones probably manufactured by Forest River. They were afraid that if they tried to open up the hose fittings, they wouldn't be able to reseal them and might have to put new fittings on the hoses, a potential disaster if their fittings wouldn't fit on the hoses or the hoses became too short after cutting off the original fittings.

I suspect that when your motor was changed, the hoses were disconnected and you now have leaks from the fittings. I'd go back to the shop that did the motor replacement and find out if they removed then reattached the hoses. If they did, then they should be responsible for fixing the leaks.

Phil Sherman
__________________

__________________
pmsherman is offline   Reply With Quote
Old 08-31-2013, 09:59 AM   #3
Member
 
Join Date: Sep 2012
Posts: 90
Thnx, I know for sure that when the shop replaced the motor, they did not put new fittings on. However, when FR transported my rig back to Elkhart, they did replace some hoses (orange color) as a part of their PDI. It will be going back to the shop for this.
__________________
MattM is offline   Reply With Quote
Reply

Tags
hydraulic, leak

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:04 AM.