Reply
 
Thread Tools Display Modes
Old 12-02-2011, 01:29 AM   #1
Member
 
Join Date: Nov 2010
Location: Lindstrom, MN
Posts: 69
Low Point Drain

Have not had this happen before, but the water in the fresh water tank would not drain out unless the water pump is running? It worked fine the last couple of years, its like its not getting vented air to drain out.?? I must be missing something, any helps out there? Its a 08 Georgtown 374TS.
Gary
__________________

__________________
Ggantilla is offline   Reply With Quote
Old 12-02-2011, 01:38 AM   #2
Moderator Emeritus
 
Join Date: Nov 2008
Location: Winston-Salem, NC
Posts: 2,381
Sounds like a clogged vent line. Did you check the vent line for blockage?

Thew pump may suck hard enough to get air by the blockage.

Just a guess.
__________________

__________________
LadyWindrider
2012 Ford F250 ext. Cab 4x4
2002 Jeep Wrangler Sahara
2008 Yamaha V-Star 650 Classic

2008 Work and Play 18LT
LadyWindrider is offline   Reply With Quote
Old 12-03-2011, 11:40 AM   #3
Member
 
Join Date: Nov 2010
Location: Lindstrom, MN
Posts: 69
Not yet, but that must be it. Thx
__________________
Ggantilla is offline   Reply With Quote
Old 12-05-2011, 01:24 PM   #4
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
This may sound stupid but take the vent hose and blow through it. The sloshing of the water when you drive down the road gets water into the line which is trapped. My tank drained very slow until I did this and afterwards it drained much better.
There are posts on here about syphoning fresh water tanks while driving. This is the remaining water in the trapped line causing the slow draining tank.
__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is online now   Reply With Quote
Old 12-05-2011, 01:32 PM   #5
Member
 
Join Date: Nov 2010
Location: Lindstrom, MN
Posts: 69
Thanks, will do that.
Its back at the dealer, after getting the lippert steps repaired 3 times, they were finally working great, and had it back at the dealer for some warranty generator issues, and they managed to run into the steps while in the shop, and nearly tore them off!!!!! absolutely unreal!
__________________
Ggantilla is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:11 PM.