Reply
 
Thread Tools Display Modes
Old 04-14-2012, 11:26 AM   #1
Member
 
Join Date: Nov 2010
Location: Lindstrom, MN
Posts: 69
low water pressure

Hello all, whenever I turn water on, pressure is fine for about 30 seconds but gets less and less.
Checked water inlet, screen was a little plugged, but didn't make any differance.
I removed the psi regulator from the hose bib, helped a little but not much.
I have never flushed the HW heater?? Could that be it? Pressure is not great at supply, but I would think good enough.
All the faucets seem to be the same, including shower and outside shower hose.
08 Georgetown.
__________________

__________________
Ggantilla is offline   Reply With Quote
Old 04-14-2012, 11:47 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Have you changed your water filter?
__________________

__________________
TURBS is offline   Reply With Quote
Old 04-14-2012, 03:15 PM   #3
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,360
Quote:
Originally Posted by f1100turbo View Post
Have you changed your water filter?

X2 Clean water filter in canister.
__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 04-14-2012, 03:37 PM   #4
Member
 
Join Date: Nov 2010
Location: Lindstrom, MN
Posts: 69
I recently changed water filter in the canister, so took it out and everything works great without the filter in. The old filter was the regular one in the canister which was hallow in the middle. The new one I got from CW, Culligan brand is not hallow in the middle, the plastic inserts on the end appear to restrict the water flow, sounds crazy I know.
I put one of the inline water filters on and left the canister one out, is that OK?
__________________
Ggantilla is offline   Reply With Quote
Old 04-14-2012, 04:12 PM   #5
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
Its fine. I'm currently running with an inline filter and no filter inside. Just lazy and didn't want to pay for a water pur replacement filter But, while researching filters, I found some that listed a higher flow. I'd suggest you look into those filters. I'll likely but from this company if I add one again. http://www.rvwaterfilterstore.com/RCCarbonCartridge.htm
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 04-14-2012, 04:18 PM   #6
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
If you got one with the ends capped off then I believe you got the wrong one.
__________________
TURBS is offline   Reply With Quote
Old 04-15-2012, 12:02 AM   #7
Member
 
Join Date: Nov 2010
Location: Lindstrom, MN
Posts: 69
That is the issue. Thx
__________________
Ggantilla is offline   Reply With Quote
Old 04-15-2012, 12:06 AM   #8
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,360
The filter I had in my FR Rockwood is one you can wash and clean then replace.
It caught the large particles and the mesh was white plastic like and not paper/
__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 04-15-2012, 12:09 AM   #9
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Filter should have both ends open .
Was your original open both ends?
__________________
TURBS is offline   Reply With Quote
Old 04-15-2012, 09:41 AM   #10
Member
 
Join Date: Nov 2010
Location: Lindstrom, MN
Posts: 69
Original did have open ends. CW had two on the shelf, one was white like the original, the other was a black or brown which I didn't really consider, but I bet it had open ends. Oh well, live and learn.
__________________

__________________
Ggantilla is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:02 AM.