Reply
 
Thread Tools Display Modes
Old 06-22-2015, 06:30 PM   #21
Senior Member
 
Join Date: Oct 2013
Location: Tigard, Oregon
Posts: 413
So, they ran it again this AM, then changed all the filters and the oil like we asked. Going to pick her up tonight, and will run that genny for sure this week! Supposed to be HOT here, and no fun to drive without the AC on.....!

I have my fingers crossed that we've solved the issue.

Thanks for all the suggestions, and if anything changes I will post!

Garren
__________________

__________________
2015 Georgetown 351DS
2016 Jeep Wrangler Unlimited Sahara
Chris, Garren (humans)
Edgar & Carlos (felines)
RIP Sophie, the sweetest cat ever.
ChrisAndGarren is offline   Reply With Quote
Old 06-22-2015, 06:49 PM   #22
Senior Member
 
Dijoeboss's Avatar
 
Join Date: May 2013
Posts: 376
On my 2013 XL I can say there are 2 problems, one is this junky auto transfer switch, it's as good as gone when I figure out what I'm gonna do with it, two - is the generator not running both a/c units when it's hot, (yes fridge is on propane / yes water heater is switch to propane) if I hit a bump or stop suddenly, the generator will shut off completely.... The Rv repair center can't duplicate a concern, so they don't know what to fix....

Don't dwell to much on the problem and enjoy your trip! It does get aggravating, but not worth the wasted mental madness. If I come up with a fix or resolve, I will definitely pass it along, I'm just getting started!!


2013 Georgetown XL 350
Bunkhouse
2002 F250 4X4 CC
2012 Jeep Liberty
__________________

__________________
Dijoeboss is offline   Reply With Quote
Old 07-08-2015, 12:58 PM   #23
Junior Member
 
Join Date: Jun 2012
Posts: 22
I just had that same problem and it was the fuel pump after 10 or 15 minutes would die out and after 10 minutes i was able to start it again. it was the fuel pump which i replaced and never another problem.
__________________
tonytiza is offline   Reply With Quote
Old 09-08-2015, 09:34 AM   #24
Senior Member
 
gmann55's Avatar
 
Join Date: Apr 2014
Posts: 265
I have a 2008 Georgetown 370 with a 5500 watt Oman gen. It has 2 fuel filters on it. 1 in front of fuel pump and 1 in front of carb. Change them both!
__________________
gmann55 is offline   Reply With Quote
Old 09-08-2015, 09:54 AM   #25
Senior Member
 
mud yapster's Avatar
 
Join Date: Aug 2014
Location: Texas
Posts: 1,162
This was when brand new from FR. My 5500 Onan did about the same thing it would run for 30 minutes then shut off then after restarting it would run 5 or 10 minutes then shut off again. Checked my fuel pump it was ok but not pumping any fuel. I traced the fuel line from the gen all the way back to the fuel tank and found the fuel line kinked off in 5 different places. The kinks were at the fuel line holding brackets that the lines were ran through. Fixed that and then it ran like a champ.
__________________
2014 Palomino Columbus 3650TH
435AH 12V VMax Charge Tanks, 520 watt Monocrystilline Solar Array, Morningstar MPPT TS-60 CC,Morningstar Remote,Cotek True Sine Wave Inverter,Cotek Remote Controller,50amp Progressive Hardwire Surge Protector
2015 Dodge 3500 6.7L 4X4
2011 CanAm Commander XT 1000
mud yapster is offline   Reply With Quote
Old 09-08-2015, 03:46 PM   #26
Member
 
MarkAnne's Avatar
 
Join Date: Oct 2014
Location: Frederick, CO
Posts: 45
I'm having recurring problem with generator. New electronic control unit $300 and new fuel filter and pump. $300 and Generator still quits and gives fuel error (3 flashes of light). I think the fuel inlet in the tank may be clogging. Does anyone know what is on the end if the fuel line which is suspended in the tank? Can it clog?

Thanks


2010 Georgetown 337 DS

Sent from my iPhone using Forest River Forums
__________________
MarkAnne is offline   Reply With Quote
Old 09-08-2015, 07:01 PM   #27
Senior Member
 
Freds342's Avatar
 
Join Date: Oct 2008
Posts: 407
Quote:
Originally Posted by gmann55 View Post
I have a 2008 Georgetown 370 with a 5500 watt Oman gen. It has 2 fuel filters on it. 1 in front of fuel pump and 1 in front of carb. Change them both!
Onan has an adapter to replace the carb end filter. You don't need two

P/N A029S253. $20.00 at RV Auto Parts.
__________________
2005 Georgetown 342DS XL, Full Banks Package
2005 Liberty Renegade 4X Toad
1989 Wrangler Sahara Toad
1984 19.5' Beachcraft i/o 5.o liter, 4-bbl (and you thought your Moho sucked gas!)
D/W Carole and Maggie the Teacup Lab (Black Chihuahua)
Freds342 is offline   Reply With Quote
Old 09-08-2015, 11:24 PM   #28
Senior Member
 
gmann55's Avatar
 
Join Date: Apr 2014
Posts: 265
The filter is a lot cheaper than the adapter!
__________________
gmann55 is offline   Reply With Quote
Old 09-14-2015, 11:14 AM   #29
Senior Member
 
gmann55's Avatar
 
Join Date: Apr 2014
Posts: 265
I also changed the oil and filter on my gen. I put Mobil 1 synthetic oil in it as I figure it will run cooler. Check the spec on your engine and add the right amount of oil. When the oil level is even a little low it will continue to shut the engine down!
__________________
gmann55 is offline   Reply With Quote
Old 09-19-2015, 12:08 PM   #30
Junior Member
 
Join Date: Mar 2015
Posts: 10
I know of two folks here in Oregon. One with a 31' class c and another with a recent model year v10 class a. They both had issues with the generator stopping after 20 minutes or so when it was hit outside. For them, the solution was to make a vent, about 8x10" in the storage bin hatch that the generator is installed in. Appears to have fixed their issues. Their issues did not occur below 80f.

I have a 2008 350. No issues with mine. The only noticeable difference between mine and theirs is that my generator is installed at the rear of the RV. On both of their rvs the generator is installed up front. They both think that the generator over heats some how because of proximity to engine heat.

Good luck.
__________________

__________________
Robert Vaughn is offline   Reply With Quote
Reply

Tags
500, generator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:11 PM.