Thread Tools Display Modes
Old 08-16-2016, 05:05 PM   #1
Junior Member
Join Date: Apr 2016
Posts: 1
Onan Genset Gold

Stopped running and gave a fault code 36 that says pick up tube in tank too high. Pulled the gas pump from tank and the hose was bad. Replaced hose and ran great for months then the same problem and fault code. Pulled it apart again and found nothing wrong. Unit will start but will stall out like it isn't getting enough gas unless you hold the choke then it will run great. Is there something else that would cause this? It looks like there is some type of pressure switch in line with the new fuel filter.
Bill6890 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:19 PM.