Reply
 
Thread Tools Display Modes
Old 05-27-2014, 01:22 AM   #11
Senior Member
 
Join Date: Jan 2009
Location: Seal Beach, Ca.
Posts: 171
Quote:
Originally Posted by Ford Idaho View Post
I do not see the model number of your unit so.

Is the stove in a slide?
It's a Magic Chef on the slide.
__________________

__________________
georgetown50 is offline   Reply With Quote
Old 05-27-2014, 01:27 AM   #12
Senior Member
 
Join Date: Jan 2009
Location: Seal Beach, Ca.
Posts: 171
Quote:
Originally Posted by kenandterry View Post
You posted that "suddenly the stove decided not to work". I'm assuming that means everything worked fine in the hours/days just before.

Aside from the hints submitted by others, are you sure the LP gas detector is still functioning okay. On my unit there is a green flashing light to indicate it is working. Without it working, it will stop the flow of gas to everything as is designed.

Have you verified the fridge switches over and runs on gas okay.....or have you verified the furnace works okay?
It worked one day, next day didn't work. No apparent reason. I just checked the LP Gas Detector and it is off and they green blinking light is off. Could this be the culprit????
__________________

__________________
georgetown50 is offline   Reply With Quote
Old 05-27-2014, 02:11 AM   #13
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,840
Quote:
Originally Posted by georgetown50 View Post
It's a Magic Chef on the slide.
One problem I have see before is a rubber gas line will get kinked from the in and out motion of the slide.

Run the slide out and check the hose.
__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Old 05-27-2014, 05:02 AM   #14
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Quote:
Originally Posted by georgetown50 View Post
It worked one day, next day didn't work. No apparent reason. I just checked the LP Gas Detector and it is off and they green blinking light is off. Could this be the culprit????
Yes, normally LP detector has to be on as it usually operates a propane solenoid at the main tank. LP detector off = solenoid de-energized and no propane.
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Reply

Tags
propane

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:57 PM.