Reply
 
Thread Tools Display Modes
Old 08-01-2014, 10:09 PM   #1
Junior Member
 
Join Date: May 2011
Posts: 10
Refrigerator Works on 110 But Not LP

My 2014 Georgetown Dometic fridge works great on 110 but stops working when on LP. The flame is burning but no cooling. My service mechanic has never seen this problem but will try to clean propane vent etc. Any ideas?
__________________

__________________
NSX1992 is offline   Reply With Quote
Old 08-02-2014, 10:30 AM   #2
Member
 
Join Date: May 2010
Location: Merritt Island Fl.
Posts: 168
when my 378 is idle for a period of time, I need to light a burner on my stove to get the gas up into the lines. try that , it will probably cure your problem.
__________________

__________________
johnnypal is offline   Reply With Quote
Old 08-02-2014, 10:49 AM   #3
Camper Less Camping
 
Cajun Po-Boy's Avatar
 
Join Date: Apr 2012
Location: NW
Posts: 3,642
Quote:
Originally Posted by johnnypal View Post
when my 378 is idle for a period of time, I need to light a burner on my stove to get the gas up into the lines. try that , it will probably cure your problem.
X2!
__________________
2013 Sabre 32RCTS-6 (sold)
Family of 4 whose always on the GEAUX!
Cajun Po-Boy is offline   Reply With Quote
Old 08-02-2014, 12:03 PM   #4
Tim & Lisa Trempert
 
Join Date: Sep 2008
Posts: 439
Quote:
Originally Posted by NSX1992 View Post
My 2014 Georgetown Dometic fridge works great on 110 but stops working when on LP. The flame is burning but no cooling. My service mechanic has never seen this problem but will try to clean propane vent etc. Any ideas?

How do you know the flame was burning? It would be very strange if electric worked yet the burning flame would not as they both work by heating up the high pressure side.


Sent from my iPhone using Forest River Forums
__________________
Tim & Lisa
2011 Georgetown 350
Trempert is offline   Reply With Quote
Old 08-02-2014, 01:30 PM   #5
Junior Member
 
Join Date: May 2011
Posts: 10
The mechanic took the shield off so you can see the flame is burning normally so the problem is not getting propane to the fridge. I have tried switching between 110 and propane with the same result. I watched the flame every hour but still no cooling. The fridge should work no matter where the heat is coming from.
__________________
NSX1992 is offline   Reply With Quote
Old 08-02-2014, 05:37 PM   #6
Member
 
Join Date: Feb 2014
Location: Garden Grove CA
Posts: 60
I had this problem in another motor home. Camping World replaced my coach batteries, converter and the electronic board in the refrigerator. There could be enough voltage to keep the burner lit so it doesn't sound like your batteries are bad.
__________________
nicholsonv is offline   Reply With Quote
Old 08-02-2014, 06:15 PM   #7
Junior Member
 
Join Date: May 2011
Posts: 10
Problem solved. The mechanic removed the orifice that the propane is shot through before the air gap and found a small dirt particle in the center hole. The tiny blockage was enough to reduce the gas flow to

prevent enough heat to operate properly. It cost me $60 instead of $1,500.
__________________

__________________
NSX1992 is offline   Reply With Quote
Reply

Tags
refrigerator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:23 AM.