Reply
 
Thread Tools Display Modes
Old 11-30-2014, 05:13 PM   #1
Member
 
Join Date: Jan 2014
Location: San Antonio
Posts: 69
Residential Fridge

My fridge will not work via battery. Battery shows full charge. Green light for invertor is on. Fridge works fine on shore and generator power. Any thoughts?


2014 GT 378 XL
__________________

__________________
jeffv003 is offline   Reply With Quote
Old 11-30-2014, 05:59 PM   #2
Senior Member
 
Join Date: May 2013
Location: Whitehouse, Texas
Posts: 693
Residential Fridge

I think I remember reading about a fuse in the inverter, that may be bad or the inverter itself.




Sent from my iPad using Forest River Forums
__________________

__________________
2013 Georgetown XL 378
2008 Honda CR-V
wrapperman is offline   Reply With Quote
Old 11-30-2014, 07:43 PM   #3
Senior Member
 
cjd10's Avatar
 
Join Date: Sep 2013
Location: Charleston SC
Posts: 481
There is a resettable breaker on the front of the inverter. Had mine open a few times. The green light on the inside will be on but no power to the refridgerator
__________________
2014 Georgetown 351DS

Charleston SC
3 Boston Terriers, 1 Frenchie
Gonna miss you Toby. RIP
cjd10 is offline   Reply With Quote
Old 11-30-2014, 07:56 PM   #4
Member
 
Join Date: Jan 2014
Location: San Antonio
Posts: 69
Where can I find the invertor? Thanks for the tips.


2014 GT 378 XL
__________________
jeffv003 is offline   Reply With Quote
Old 11-30-2014, 08:49 PM   #5
Senior Member
 
cjd10's Avatar
 
Join Date: Sep 2013
Location: Charleston SC
Posts: 481
Not sure on a 378. Mine is in compartment just to the right of the water heater. Have to remove the round white cap to see in. You should see the 120 V outlet on the front of it.
__________________
2014 Georgetown 351DS

Charleston SC
3 Boston Terriers, 1 Frenchie
Gonna miss you Toby. RIP
cjd10 is offline   Reply With Quote
Old 11-30-2014, 09:02 PM   #6
Senior Member
 
cjd10's Avatar
 
Join Date: Sep 2013
Location: Charleston SC
Posts: 481
This is what it looks like when you find it. The reset is in between the outlets
Attached Thumbnails
Click image for larger version

Name:	DSC_0260.jpg
Views:	135
Size:	239.8 KB
ID:	66967  
__________________
2014 Georgetown 351DS

Charleston SC
3 Boston Terriers, 1 Frenchie
Gonna miss you Toby. RIP
cjd10 is offline   Reply With Quote
Old 11-30-2014, 09:44 PM   #7
Senior Member
 
Join Date: May 2013
Location: Whitehouse, Texas
Posts: 693
My 2013 378 XL is locate above the LP tank. Take off the black plastic panel.


Sent from my iPad using Forest River Forums
__________________
2013 Georgetown XL 378
2008 Honda CR-V
wrapperman is offline   Reply With Quote
Old 12-01-2014, 12:15 PM   #8
Member
 
alsimmon11's Avatar
 
Join Date: Apr 2011
Posts: 71
Took my 2010 GT 378 out this weekend. Turned on the fridge using LP when I picked it up. Once at the park I switched over to shore power. Temp was on 60 for several hours. Next day no change in temp, freezer was on but still no fridge. Switched back to LP and after about 4-5 hours temp started to drop. During the end of a 4 day trip the temp got down to 34. Normally it would take about 6-8 hours and fridge and freezer would be fine. Outside temp in Ca was around 70 deg. Any suggestions.
__________________
alsimmon11 is offline   Reply With Quote
Old 12-01-2014, 04:44 PM   #9
Senior Member
 
Join Date: May 2013
Location: Whitehouse, Texas
Posts: 693
I don't know much about LP/electric but what I would check is to see if the electric element is working properly. Might even be a breaker, fuse or temperature sensor.
That is if when it is on LP it works fine.
I will ask a friend that has your type of fridge and let you know what he suggests.


Sent from my iPad using Forest River Forums
__________________
2013 Georgetown XL 378
2008 Honda CR-V
wrapperman is offline   Reply With Quote
Old 12-01-2014, 04:57 PM   #10
Senior Member
 
Join Date: May 2013
Location: Whitehouse, Texas
Posts: 693
My friend said if it works on LP but not on electric then check for a tripped circuit breaker.
Check to make sure heating element is getting hot.
Low heat can give a fairly cool freezer part and not a cold refridge area.
It could even be the control module.
Hope you can find the problem without much expense or hassle.



Sent from my iPad using Forest River Forums
__________________

__________________
2013 Georgetown XL 378
2008 Honda CR-V
wrapperman is offline   Reply With Quote
Reply

Tags
fridge

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:06 PM.