Reply
 
Thread Tools Display Modes
Old 04-11-2015, 11:17 PM   #1
Member
 
CheckSix's Avatar
 
Join Date: Dec 2014
Posts: 98
School me on the Rear, Left & Right Cameras

After the sway bar install, I drove home in the dark for the first time. I noticed when I turned the headlights on, the camera monitor switched from rear view, to left view. Then, when I turn right with the blinker, the rear view shows up but it blinks the monitor display, in unison with the blinker. The right camera does not work anymore. IIf I turn the headlights off, the monitor goes back to the rear view camera view and the right camera works correctly with the blinker on.

What am I doing wrong?
__________________

__________________
2012 Georgetown 327DS--->2015 Georgetown XL 369DS
CheckSix is offline   Reply With Quote
Old 04-11-2015, 11:56 PM   #2
Senior Member
 
abjb's Avatar
 
Join Date: Dec 2011
Posts: 548
You've got a/some lights burned out or corroded, check them all.
__________________

__________________
2012 Georgetown 360
SHE wanted "a new motorhome"
abjb is offline   Reply With Quote
Old 04-12-2015, 11:36 AM   #3
Senior Member
 
silver's Avatar
 
Join Date: Oct 2011
Posts: 739
Were the cameras installed by the factory or are they after market installed by a previous owner? Almost sounds like the trigger for side cameras are tied into marker lights rather than directional. After market install make this mistake as side markers are easier to cut in to.
__________________
silver is offline   Reply With Quote
Old 04-12-2015, 11:39 AM   #4
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,360
X2
Don't make it more complicated. You do have a bulb burnt out. Check all lights.
__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 04-12-2015, 12:01 PM   #5
Member
 
CheckSix's Avatar
 
Join Date: Dec 2014
Posts: 98
It's factory.

I'll check the light bulbs today.

Thanks!
__________________
2012 Georgetown 327DS--->2015 Georgetown XL 369DS
CheckSix is offline   Reply With Quote
Old 04-12-2015, 05:32 PM   #6
Member
 
CheckSix's Avatar
 
Join Date: Dec 2014
Posts: 98
All light bulbs on the exterior are working. When I checked it today, after turning on the headlights, it switched from rear view, to left view but when I turned on the fog lights, that switched it back to rear view. It then behaved what I consider normally, WRT turn signals and camera views.

Is this system prone to gremlins? Seems so.
__________________
2012 Georgetown 327DS--->2015 Georgetown XL 369DS
CheckSix is offline   Reply With Quote
Old 04-12-2015, 06:23 PM   #7
Member
 
Bubbamace's Avatar
 
Join Date: Dec 2013
Location: Beautiful California
Posts: 83
Quote:
Originally Posted by CheckSix View Post
All light bulbs on the exterior are working. When I checked it today, after turning on the headlights, I switched from rear view, to left view but when I turned on the fog lights, that switched it back to rear view. It then behaved what I consider normally, WRT turn signals and camera views.

Is this system prone to gremlins? Seems so.
I have the same system installed at the factory. Turning on the headlamps and fog lamps do not affect my system. When I turn on the left turn signal, the left camera comes on and then the same for the right signal, the right camera comes on. When I back the rear view camera comes on. I can go in the menu and set the rear camera to be on at all times when I'm travelling if I'm interested in what is happening with a trailer or toad. I believe that something is not wired correctly or perhaps a bulb is out (I wasn't aware a bulb out could affect the system). I did find one of the camera wires off one time and reconnected it. Left camera, but it just wouldn't work. Also, I found one wire off behind the camera/radio system. the wire connector had fallen out of the radio system, so you might check there. I travel some rough roads out in the desert and I'm sure this caused the problem. Good luck and let us know what happened.
__________________
Bubbamace is offline   Reply With Quote
Old 04-12-2015, 11:48 PM   #8
Senior Member
 
abjb's Avatar
 
Join Date: Dec 2011
Posts: 548
Quote:
Originally Posted by CheckSix View Post
All light bulbs on the exterior are working. When I checked it today, after turning on the headlights, it switched from rear view, to left view but when I turned on the fog lights, that switched it back to rear view. It then behaved what I consider normally, WRT turn signals and camera views.

Is this system prone to gremlins? Seems so.
Ours works like yours, the sockets get corroded. Every time I get a chance I use contact cleaner and apply dielectric grease
Permatex/Dielectric tune-up grease 22058 at AutoZone.com
to a few bulbs/sockets. last year I had to do 5 just to pass the state inspection.

Here are a few threads with similar problems.
Camera not working

Side cameras - 360

Side View Camera
__________________
2012 Georgetown 360
SHE wanted "a new motorhome"
abjb is offline   Reply With Quote
Old 04-13-2015, 11:20 AM   #9
Member
 
Bubbamace's Avatar
 
Join Date: Dec 2013
Location: Beautiful California
Posts: 83
By the way, when I found the camera line unplugging, I didn't remove any screws or panels. I was able to lay down and see the back of the receiver/stereo and observe the plug that was out. That simple for me.
__________________
Bubbamace is offline   Reply With Quote
Old 04-13-2015, 12:41 PM   #10
Member
 
CheckSix's Avatar
 
Join Date: Dec 2014
Posts: 98
In my case, everything is plugged in and all bulbs are working. The camera monitor system seems to do what it wants sometimes, until I interrupt it with fog lights or headlights being switched on or off.

I'll have to get into the system and see how the preferences are set up.
__________________

__________________
2012 Georgetown 327DS--->2015 Georgetown XL 369DS
CheckSix is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:43 AM.