Reply
 
Thread Tools Display Modes
Old 08-07-2015, 08:04 PM   #1
Member
 
Starboard's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 69
Shore power cord lights

Howdy folks,
I just got back from a trip and noticed that my shore power only has one blue LED lit. I thought I remember it had two lit at the same time at one point - can anyone shine any light on this?
Is there a fuse tripped somewhere?
__________________

__________________
Starboard is offline   Reply With Quote
Old 08-07-2015, 08:13 PM   #2
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 5,550
Many posts here about the blue LEDs failing.
__________________

__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is offline   Reply With Quote
Old 08-07-2015, 08:36 PM   #3
Member
 
Starboard's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 69
Really? I can't find a single one.. Care to share a link?
__________________
Starboard is offline   Reply With Quote
Old 08-10-2015, 12:45 PM   #4
Member
 
Starboard's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 69
Bump... Does anyone have any answers to this?
__________________
Starboard is offline   Reply With Quote
Old 08-10-2015, 06:01 PM   #5
Senior Member
 
MacDR's Avatar
 
Join Date: Feb 2014
Location: Kenosha Wisconsin
Posts: 508
One of my Led's failed also.. I had both my 50 amp breaker checked and my shore power cord.. Everything checked out fine .. My electrician told mento to worry about it..


Greetings from Wisconsin
__________________
2013 Ram 2500 "Cummins"
2014 Columbus 340RK
Day's Camped 2017 "21"
You can find us in Egg Harbor, WI 7/14 -7/17
MacDR is offline   Reply With Quote
Old 08-10-2015, 06:10 PM   #6
Senior Member
 
gashog's Avatar
 
Join Date: Aug 2014
Location: Kansas
Posts: 343
both my blue leds on the shore line cord lite, but the blue led on the furrion cover on the TT no longer lites...

just went to Furrion's web site and filled out their warranty form see what happens...
http://furrion.com/contact-us/
__________________
2015 Rockwood Windjammer 3029W Diamond Package

2014 RAM 2500 Laramie Longhorn 4 x 4
6.4 Hemi 410 HP, 410 Rear Axle
gashog is offline   Reply With Quote
Old 08-14-2015, 04:07 PM   #7
Junior Member
 
Join Date: Aug 2015
Posts: 1
Ive had the same problem. cord works no lights. Just another du dad that fails. I emailed furrion also no reply in two weeks.

Sent from my SM-N910P using Tapatalk
__________________
uppie89 is offline   Reply With Quote
Old 08-14-2015, 04:23 PM   #8
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 5,550
Quote:
Originally Posted by Starboard View Post
Bump... Does anyone have any answers to this?
Bump see above
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is offline   Reply With Quote
Old 08-14-2015, 04:35 PM   #9
Senior Member
 
gashog's Avatar
 
Join Date: Aug 2014
Location: Kansas
Posts: 343
I contacted Furrion through their web site. One of their rep (Al) called me the next day. A new Power Input Plug-in is on its way. He did say I likely had a power surge, which I didn't because I'm running a Progressive Industry EMS
__________________
2015 Rockwood Windjammer 3029W Diamond Package

2014 RAM 2500 Laramie Longhorn 4 x 4
6.4 Hemi 410 HP, 410 Rear Axle
gashog is offline   Reply With Quote
Old 08-14-2015, 09:11 PM   #10
Senior Member
 
DK-in-SC's Avatar
 
Join Date: Jun 2014
Location: Tega Cay, SC
Posts: 522
If the end of the cord with the LEDs gets wet they will likely fail. Happened to me when using an extension cord. Normally the end with the LEDs are under the flap on the power pole.
Sent several email messages to them and left a few messages on the voicemail - nothing. Tough to get in touch with them but when I finally did, they sent out a new cord right away.


Sent from my iPhone using Forest River Forums
__________________

__________________
I live with fear every day, and sometimes she lets me go fishing.

2015 Shamrock 23IKSS
2008 Ford Expedition EL
DH-DW-D3K-DMTTSAP
DK-in-SC is offline   Reply With Quote
Reply

Tags
light, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:57 PM.