Reply
 
Thread Tools Display Modes
Old 08-13-2016, 11:02 AM   #1
Senior Member
 
mr.ken's Avatar
 
Join Date: May 2009
Location: Southwest Florida
Posts: 162
Side cameras don't work

I have a 2010 357 qs and the side cameras aren't working. Has anyone had any issues or know what it could possibly be. All I have done is check connections at the monitor


Sent from my iPhone using Forest River Forums
__________________

__________________
2010 Georgetown 357qs
2009 chevy hhr
2007 chevy silverado
mr.ken is offline   Reply With Quote
Old 08-13-2016, 03:04 PM   #2
Senior Member
 
Join Date: May 2013
Location: Whitehouse, Texas
Posts: 552
Have you tried the connection at the camera video switch?
__________________

__________________
2013 Georgetown XL 378
2008 Honda CR-V
wrapperman is offline   Reply With Quote
Old 08-13-2016, 08:39 PM   #3
Senior Member
 
chrisbailey13's Avatar
 
Join Date: Apr 2014
Posts: 371
Quote:
Originally Posted by mr.ken View Post
I have a 2010 357 qs and the side cameras aren't working. Has anyone had any issues or know what it could possibly be. All I have done is check connections at the monitor


Sent from my iPhone using Forest River Forums
Can you elaborate on the symptoms? when you turn on the signal what happens with the camera? does the rear view camera work?
__________________
2014 Georgetown XL 352QS
2013 Days Camped-10 (in a rental)
2014 Days Camped-52
2015 Days Camped-53

2016 Days Camped-39
chrisbailey13 is offline   Reply With Quote
Old 08-14-2016, 09:20 AM   #4
Senior Member
 
mr.ken's Avatar
 
Join Date: May 2009
Location: Southwest Florida
Posts: 162
Yes. The rear camera works. If you turn on either signal the screen goes black like it was going to change to a side camera then the rear camera comes back on


Sent from my iPhone using Forest River Forums
__________________
2010 Georgetown 357qs
2009 chevy hhr
2007 chevy silverado
mr.ken is offline   Reply With Quote
Old 08-14-2016, 02:39 PM   #5
Senior Member
 
chrisbailey13's Avatar
 
Join Date: Apr 2014
Posts: 371
Quote:
Originally Posted by mr.ken View Post
Yes. The rear camera works. If you turn on either signal the screen goes black like it was going to change to a side camera then the rear camera comes back on


Sent from my iPhone using Forest River Forums
Check your side marker/turn signal bulbs. I have seen that symptom when the a bulb is burned out.

May not be your situation, but it is a start.
__________________
2014 Georgetown XL 352QS
2013 Days Camped-10 (in a rental)
2014 Days Camped-52
2015 Days Camped-53

2016 Days Camped-39
chrisbailey13 is offline   Reply With Quote
Old 08-15-2016, 03:18 PM   #6
Senior Member
 
mr.ken's Avatar
 
Join Date: May 2009
Location: Southwest Florida
Posts: 162
I will do that.....thanks


Sent from my iPhone using Forest River Forums
__________________
2010 Georgetown 357qs
2009 chevy hhr
2007 chevy silverado
mr.ken is offline   Reply With Quote
Old 08-15-2016, 08:24 PM   #7
Senior Member
 
Join Date: Jul 2013
Location: Broken Arrow, OK
Posts: 130
Mr Ken
There is a video switch on the floor just to the right of the gas pedal that the cameras plug into. There's 3 cables in a row that are from the cameras. Left, center and right. You can swap them around while on and see if they will work. They were always getting loose on mine and going black. Just reseat and fine.


Sent from my iPhone using Forest River Forums
__________________
Bill

2015 Charleston 430RB
Billr is online now   Reply With Quote
Old 08-16-2016, 10:18 AM   #8
Senior Member
 
mr.ken's Avatar
 
Join Date: May 2009
Location: Southwest Florida
Posts: 162
Quote:
Originally Posted by Billr View Post
Mr Ken
There is a video switch on the floor just to the right of the gas pedal that the cameras plug into. There's 3 cables in a row that are from the cameras. Left, center and right. You can swap them around while on and see if they will work. They were always getting loose on mine and going black. Just reseat and fine.


Sent from my iPhone using Forest River Forums

Thanks. I will check that out when I get home
__________________
2010 Georgetown 357qs
2009 chevy hhr
2007 chevy silverado
mr.ken is offline   Reply With Quote
Old 10-12-2016, 09:55 AM   #9
Senior Member
 
mr.ken's Avatar
 
Join Date: May 2009
Location: Southwest Florida
Posts: 162
Took a bit to get to it. One of the forward turn signals was out. Replaced it with no change. The side turn signals work but both lost their Lens covers. Still searching for a cause


Sent from my iPhone using Forest River Forums
__________________
2010 Georgetown 357qs
2009 chevy hhr
2007 chevy silverado
mr.ken is offline   Reply With Quote
Old 10-12-2016, 10:42 AM   #10
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 5,947
Check ALL your side and top marker light and turn signal bulbs.
__________________

__________________
2012 Georgetown XL - 378TS 49,900 miles
(2013 - 98 days) (2014 - 117 days) (2015 - 67 days) (2016 - 111 days) (2017 Est 115)
USAF Retired - MSgt

Iggy is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:34 AM.