Thread Tools Display Modes
Old 02-22-2016, 10:40 AM   #1
Senior Member
Join Date: May 2012
Location: Northeast Alabama
Posts: 103
Tow/Haul not working

There was some previous discussion regarding the Tow/ Haul function not working and the indicator not lighting on the instrument cluster. I had a similar problem.
After checking all fuses, as well as # 18 as suggested, and removing the steering column housing to visually check for broken wires, I took it to a Ford dealer.
They found a wiring problem somewhere in the shifter arm. They replaced the shifter arm that also included a new Tow/Haul button and wires. The total cost of repair with parts and labor was 235.00.
Thanks to everyone for their input and ideas. I know a lot more about the Tow/Haul function than I previously had.
Jim G is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:12 PM.