Reply
 
Thread Tools Display Modes
Old 04-15-2014, 09:52 PM   #1
Member
 
Join Date: Mar 2014
Posts: 51
Water Filter Issues

We have had issue after issue with our '14 GT 351ds. The latest is the water filter. We were camping 2 weekends ago and it kept busting off if the water pump was off after a few minutes. Water pours everywhere. My husband took the filter out and the plastic housing and that let us make It through that weekend. This past weekend, we got stopped at a truck stop. I turned on water pump to be able to wash hands, and such. And it busted again. Now every time we turn the pump on within 2 mins, the clear plastic cup busts off. He's tightened it as tight as he possibly can with the o-wrench, but it always busts off. Any others out there dealing with this? And if so, what was the magic fix??
__________________

__________________
Campingmomx4 is offline   Reply With Quote
Old 04-15-2014, 09:55 PM   #2
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Quote:
Originally Posted by Campingmomx4 View Post
We have had issue after issue with our '14 GT 351ds. The latest is the water filter. We were camping 2 weekends ago and it kept busting off if the water pump was off after a few minutes. Water pours everywhere. My husband took the filter out and the plastic housing and that let us make It through that weekend. This past weekend, we got stopped at a truck stop. I turned on water pump to be able to wash hands, and such. And it busted again. Now every time we turn the pump on within 2 mins, the clear plastic cup busts off. He's tightened it as tight as he possibly can with the o-wrench, but it always busts off. Any others out there dealing with this? And if so, what was the magic fix??
Have the dealer replace the whole water filter unit.
__________________

__________________
OldCoot is offline   Reply With Quote
Old 04-16-2014, 10:41 AM   #3
Senior Member
 
Join Date: Sep 2013
Location: Gahanna, OH
Posts: 1,414
There is another member here having the same issue. He stated that he removed the housing under shore water pressure. That may have caused damage on the housing or the base. Inspect the housing to make sure all the teeth are intact. Also check for cracks on the base.

Contact FR to see if they'll send you a new one. It's easily installed with two hose clamps. We've never had an issue with ours and I have removed/installed a couple of times without pressure in the lines.

__________________
2014 Georgetown 351DS
-TruCenter -Front/Rear CHF -Hellwig Links -Tiger Trak -Ran McNally GPS -ScanGauge -Truck Systems TPMS -5 Star Tune
alparmer is offline   Reply With Quote
Old 04-21-2014, 09:44 AM   #4
Junior Member
 
Join Date: Jan 2014
Posts: 12
Hello Campingmomx4,

I am the other person that was having the same problem. I think I have resolved the issue. I mistakenly over tighten the plastic housing. There is a sweet spot of alignment. I found this out by ordering a whole new unit and Lauren at Forestriver mentioned the the new unit has alignment marks out it to make sure it is align properly. Well I got the new unit and saw the marks and it got me thinking that maybe the old unit was not broken just misaligned. Sure enough I did not tighten the unit to the max, just so you could read the long label centered in the housing. I will try to take a photo and posted to show you the exact position. Since I did this I have not had any problems with the housing falling off. Hope it works for you!
Dennis
__________________
dgingell is offline   Reply With Quote
Old 04-21-2014, 01:35 PM   #5
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 6,359
Remember the replacement filter is open on both ends.
If you buy one with one closed end it will sit high in the clear plastic and not allow it to totally screw on the housing.
Just a thought.
These are the replacement ones I use from Home Depot on my water cartridge.
GE Carbon Replace Filter 2-Pack-FXWTC at The Home Depot
Attached Thumbnails
Click image for larger version

Name:	April_17_2012 039.jpg
Views:	71
Size:	63.5 KB
ID:	50572   Click image for larger version

Name:	Water_Filter.jpg
Views:	74
Size:	30.0 KB
ID:	50573  
__________________
2012 Georgetown XL - 378TS 60,000 miles
Life is a journey, not a destination !

Iggy is offline   Reply With Quote
Old 04-21-2014, 02:38 PM   #6
Junior Member
 
Catsailor's Avatar
 
Join Date: Jan 2013
Posts: 8
I had the same issue with my 2013 35QB4. Requested replacement from my dealer with no issues as I was still under warranty. I since then have started carrying a flexible stainless steel 12" PEX connector so that if this happens again I can remove the filter and bypass it with the flexible connector.
__________________
______________________________
2002 Ford F350 7.3 Powerstroke
2013 CC Silverback 35QB4
Catsailor is offline   Reply With Quote
Old 04-21-2014, 05:12 PM   #7
Senior Member
 
Join Date: Jan 2013
Posts: 192
i have a 335DS and mine looks nothing like that. I have a solid white casing and i made the mistake of tossing the filter last fall. I guessed and got a camco filter 40621 that seems to fit and work. No idea what the model is that is actually installed as it has no labeling on it.
__________________

__________________
fullenw is offline   Reply With Quote
Reply

Tags
water, water filter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:15 PM.