Reply
 
Thread Tools Display Modes
Old 09-24-2009, 04:22 PM   #1
Junior Member
 
Join Date: Sep 2009
Posts: 1
Weather Pro

Hey everyone....I'm new to the forum so you'll be hearing from me now too. Nice to "meet" you. I've had my G'Town for about a year. I use the remote most of the time to extend and retract the awning. The switch going up the steps into the coach has not worked in a good while. Also, the swith at the awning motor works when it wants to. Anyway, lately when I've used the remote the awning grunts and jerks as it extends. I thought the remote battery might need replacing, so I did that. That didn't fix the problem. And when I extended it the other day, the awning stuck and would not retract. A few hours later I tried the remote and the awning went in. The RV stays plugged up to power. So...does this sound like a battery issue to you guys instead of an awning issue? Also, is the awning supposed to extend and retract smoothly or does yours jerk and grunt like mine? Please respond.
__________________

__________________
2007 Georgetown 315 is offline   Reply With Quote
Old 09-24-2009, 07:46 PM   #2
Senior Member
 
Join Date: Sep 2007
Posts: 3,260
Quote:
Originally Posted by 2007 Georgetown 315 View Post
Hey everyone....I'm new to the forum so you'll be hearing from me now too. Nice to "meet" you. I've had my G'Town for about a year. I use the remote most of the time to extend and retract the awning. The switch going up the steps into the coach has not worked in a good while. Also, the swith at the awning motor works when it wants to. Anyway, lately when I've used the remote the awning grunts and jerks as it extends. I thought the remote battery might need replacing, so I did that. That didn't fix the problem. And when I extended it the other day, the awning stuck and would not retract. A few hours later I tried the remote and the awning went in. The RV stays plugged up to power. So...does this sound like a battery issue to you guys instead of an awning issue? Also, is the awning supposed to extend and retract smoothly or does yours jerk and grunt like mine? Please respond.
First off to FRF. I am sorry I do not have a Georgtown, and it's sad to hear that you have issues but hang in there many fantastic members here that can help. Good Luck.....
__________________

__________________
rockwood06 is offline   Reply With Quote
Old 09-25-2009, 01:03 AM   #3
Senior Member
 
NWJeeper's Avatar
 
Join Date: Aug 2008
Location: Enumclaw, WA
Posts: 2,617
Haven't yet had that problem with our awning and our rig is now a year old. Check the warranty on the awning. Even though the coach only has a 1 year warranty from FR some of the components may have longer waranties from their manufacturers. Sounds like the motor on the awning isn't getting enough voltage to me but just a theory. Batteries in the remote would have nothing to do with what you describe.
__________________
"I can fix it, and if I can't fix it, I can fix it so no one can fix it!"
Ed & Wendy
2009 Georgetown 378TS | 1998 Jeep Wrangler | 1998 Skeeter ZX202C
Nights camped in 2009: 53 | Nights camped in 2010: 55
www.nwjeepn.com
NWJeeper is offline   Reply With Quote
Old 09-25-2009, 07:32 AM   #4
Senior Member
 
Join Date: Mar 2008
Location: Jacksonville Florida
Posts: 1,263
Sounds like the moving parts need lubrication, to me, or possibly the motor is dragging. I also do not believe it is a battery related problem. It should be an A&E/Dometic awning, the same as most of us with power awnings have, and like NWJeeper says, you may still be in warranty. Good Luck! Randy
__________________
/SIGPIC]'08 V-lite Flagstaff 30WRLS
'06 Ram 1500 QC hemi Reese dual cam sway control,
K&N series 77 intake, Hellwig helper spgs. LT tires,
Flowmaster "true duals", 380 h.p., Bilstein shocks
08flagvlite is offline   Reply With Quote
Old 09-25-2009, 09:08 AM   #5
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
We haven't had any problems with the awning, ours runs in and out smoothly. We've had our GT since November of 2006. If the awning switch doesn't operate the awning I'd remove it from the wall and see if something is disconnected. Also there is the power box in the compartment next to the door. Open that up and check it for anything that may not connected or loose. If everything looks ok then I'd check with Dometic about the warranty.Here's a link for the owners manual. Maybe there's something there to try and reset the awning power. Good luck, let us know what you find.

http://www.dometic.com/39ddef5d-f22c...b38c2008.fodoc
__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:22 AM.