Thread Tools Display Modes
Old 04-23-2010, 04:07 PM   #1
Junior Member
Join Date: Apr 2010
Location: mn.
Posts: 16
Elect. problem

I just went on dry run and when I plugged in at campsite I blew the breaker, I shut off my breaker turned theirs back on then mine worked fine on 110 but the 30 amp. keeps popping breakers, any ideas

Old Wrinkles

wrinkles is offline   Reply With Quote
Old 04-23-2010, 04:12 PM   #2
Senior Member
powerboatr's Avatar
Join Date: Aug 2006
Location: homebase Quitman Texas at Lake Fork
Posts: 1,388
i take it your rig is a 30 amp corded unit
if so, make sure your water heater it turned off and the fridge on propane
and the a/c is off
i would bet if the wh and fridge both are on a/c power they are straining a weak 30 amp pedestal breaker, then if you add a load it trips
my fridge will pull 5-7 amps
and wh easily pulls 12-14
add 10-12 for a running ac and your out of amps, not to mention the start up on the ac is probably spiking over 15 at start if not higher

when we hook up to 30 amp pedestals i use fridge on gas and the wh on gas to leave room for the micro and ac.

Living in the Piney Woods of Texas.
powerboatr is offline   Reply With Quote
Old 04-23-2010, 04:16 PM   #3
Junior Member
Join Date: Apr 2010
Location: mn.
Posts: 16
Hi Powerboatr
Thanks for the reply my wh was off as well as refer on gas and the ac was off I wonder if a problem exists with both pole and me having ground faults, just not sure
wrinkles is offline   Reply With Quote
Old 04-23-2010, 05:49 PM   #4
Senior Member
TulsaSteve's Avatar
Join Date: Oct 2007
Location: Tulsa
Posts: 309
Could be an improperly grounded circuit at the campground. Can you move to another slot?
TulsaSteve is offline   Reply With Quote
Old 04-23-2010, 10:16 PM   #5
Senior Member
Join Date: Mar 2008
Location: Jacksonville Florida
Posts: 1,263
My rig is 30 amps as well, and your setup should handle everything with no problems. Hey, when wer'e on an electric site, why burn up your propane??? I run my AC, water heater, refrigerator, and the interior lights witout a problem ever in 2 years. Only once I tripped the breaker on the outside box because cooking breakfast with an electric skillet was too much for the system and overloaded it. Turned the air off, and we were fine. The box as stated was probably not grounded well enough. Good luck! Randy
/SIGPIC]'08 V-lite Flagstaff 30WRLS
'06 Ram 1500 QC hemi Reese dual cam sway control,
K&N series 77 intake, Hellwig helper spgs. LT tires,
Flowmaster "true duals", 380 h.p., Bilstein shocks
08flagvlite is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:44 PM.