Reply
 
Thread Tools Display Modes
Old 03-22-2015, 11:07 AM   #1
Member
 
Join Date: Sep 2014
Posts: 59
Trouble with electric step

The step on my 2007 Lexi has apparently stopped working. I can hear the motor wanting to start and a tiny little bit of step movement occurs, but then it stops. I have it hooked up to my house power just to make sure that it isn't the battery being low. This started as an intermittent problem during the winter and I wondered if it was due to the cold, but it's 55 out today and not working. Anyone with experience with this out there that could give me advice on something to look at or lube?
__________________

__________________
heb1024 is offline   Reply With Quote
Old 03-25-2015, 09:13 PM   #2
Member
 
Join Date: Sep 2014
Posts: 59
Well it magically started working again. Is it possible that the battery was so low that it needed to be charged for a while before it would work, event though I had the camper plugged into my 20 amp house power?
__________________

__________________
heb1024 is offline   Reply With Quote
Old 04-17-2015, 09:19 PM   #3
Member
 
Hamm123's Avatar
 
Join Date: May 2014
Location: Arkansas
Posts: 52
My SCS/frigette step is making a noise when I turn ignition on or flip the switch inside the coach by the door but will not retract the step. I am going to look at the ground in the morning and the magnet on screen door. I sure hope it's something simple for the mechanically challenged guy.


Sent from my iPad using Forest River Forums
__________________
Hamm123 is offline   Reply With Quote
Old 04-17-2015, 09:24 PM   #4
Member
 
Join Date: Sep 2014
Posts: 59
That is exactly what mine is doing. It works intermittently and then stops again. I will be interested to hear what you find when you look - I am quite sure I am less mechanical than you.
__________________
heb1024 is offline   Reply With Quote
Old 04-17-2015, 09:30 PM   #5
Member
 
Hamm123's Avatar
 
Join Date: May 2014
Location: Arkansas
Posts: 52
I will let You know, I did a search and have found some things to try.


Sent from my iPad using Forest River Forums
__________________
Hamm123 is offline   Reply With Quote
Old 04-17-2015, 09:54 PM   #6
Member
 
Join Date: Sep 2014
Posts: 59
Great!
__________________
heb1024 is offline   Reply With Quote
Old 04-18-2015, 08:44 AM   #7
Member
 
Hamm123's Avatar
 
Join Date: May 2014
Location: Arkansas
Posts: 52

Name:   ImageUploadedByForest River Forums1429360582.228005.jpg
Views: 227
Size:  74.1 KB

Name:   ImageUploadedByForest River Forums1429360613.527932.jpg
Views: 233
Size:  132.0 KB

Name:   ImageUploadedByForest River Forums1429360634.109927.jpg
Views: 226
Size:  120.7 KB

Name:   ImageUploadedByForest River Forums1429360697.251774.jpg
Views: 225
Size:  107.1 KB
Well, I looked at screen door magnet and wire connectors beside the door step entrance and just jiggled the connectors and now it is working,,, thinking about trying to solder the wires. I am glad the step is now working!


Sent from my iPhone using Forest River Forums
__________________
Hamm123 is offline   Reply With Quote
Old 04-23-2015, 08:57 AM   #8
FLORIDA F.R.O.G.
 
RickLSmith53's Avatar
 
Join Date: Sep 2012
Location: Mt Olive Shores North RV Community
Posts: 278
Electric Step Troubles & Fix

If your step is oscillating back & forth, you may have stripped the plastic spacers around the large gear in the gearbox. This can easily happen if you step on it with full weight as it is going in or out. Many of the Kwikee steps use a late 90's Ford Taurus drivers side power window motor assembly. If the motor is OK, you can usually use the window motor rebuild kit available from most auto parts stores, or eBay. (+_ $15.00) It is called a Ford Power Window Power Gear Kit. You can also find vids on YouTube showing you how to do the job... Or you can get the replacement motor assembly from Kwikee for about $200.
__________________
RickLSmith53 is offline   Reply With Quote
Old 04-23-2015, 09:34 PM   #9
Member
 
Join Date: Sep 2014
Posts: 59
Thanks Rick! I will check that out! The motor still seems okay as it is still trying to open the step but seems to run into a block - then every once in a while it will work. More often than not now it doesn't work though.
__________________
heb1024 is offline   Reply With Quote
Old 04-26-2015, 04:17 PM   #10
Senior Member
 
Lexi2007's Avatar
 
Join Date: Jun 2014
Posts: 162
Coincidence

Our 2007 Lexi step quit working in the extended position. We can hear the motor working [right now it's on shore power] but it's not budging a bit. The MH has been sitting on property for a while and the soil is quite sandy. I suspect maybe some sand might have gotten into it when it rained. The other thing is I accidentally flooded the unit and I'm wondering if some water seeped somewhere it shouldn't have and that has something to do with it. Hoping we can figger this out on our own.
__________________

__________________
Ken & Val [Lexi's mom] Moczygemba & Tori the dog
Adkins, TX
2017 Coachmen Concord 300 DS [Lexi III]
Lexi2007 is offline   Reply With Quote
Reply

Tags
electric

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:41 PM.