Reply
 
Thread Tools Display Modes
Old 06-05-2014, 12:58 PM   #1
Senior Member
 
Join Date: Feb 2013
Location: plymouth ma
Posts: 129
3050s converter

my converter seems to enjoy blowing fuses. first i can not locate a 35am fuse any place all stores have 30 and that is what i use . when i replace all seems fine for about a month and then we blow a fuse. all my 110 works and none of my dc is off. nothing changes as the unit sits in the driveway with the same shore power, and yes i have a surge protector on it. i check the batteries all seem fine, just do not understand why it blows fuses so slowly thaks for any help
__________________

__________________
oldnewguy is offline   Reply With Quote
Old 06-05-2014, 01:11 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Which fuse is blowing?

TURBS


"Sabre owners united"
__________________

__________________
TURBS is offline   Reply With Quote
Old 06-05-2014, 01:16 PM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Like yours ?

TURBS


"Sabre owners united"
Attached Thumbnails
Click image for larger version

Name:	1401988595774.jpg
Views:	97
Size:	69.2 KB
ID:	54399  
__________________
TURBS is offline   Reply With Quote
Old 06-05-2014, 09:52 PM   #4
Senior Member
 
wesslvm's Avatar
 
Join Date: Apr 2013
Posts: 202
i had same problem on my 3050 this year. Turned out I had a failed battery. BTW, I had to order the fuses (two of them on the converter itself) from Amazon as I couldn't find them locally.
__________________
2014 Sunseeker 3050S
Honda CRV (TOAD)
wesslvm is offline   Reply With Quote
Old 06-06-2014, 12:15 PM   #5
Senior Member
 
Join Date: Feb 2013
Location: plymouth ma
Posts: 129
3050 converter

a battery going down might explain why i get different readings on battery power. some days at voltage next day below voltage next day high again. also fuse will not blow every time with a battery going weak that would change things thanks for the tip keep on camping
__________________
oldnewguy is offline   Reply With Quote
Old 06-06-2014, 12:37 PM   #6
Senior Member
 
wesslvm's Avatar
 
Join Date: Apr 2013
Posts: 202
Same to you! BTW, I think my bad battery that was causing the problems was actually my chassis battery. I killed the battery by leaving it connected while in winter storage outside for 6 months. Won't make that mistake again!
__________________

__________________
2014 Sunseeker 3050S
Honda CRV (TOAD)
wesslvm is offline   Reply With Quote
Reply

Tags
305, 3050s, converter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:14 AM.