Reply
 
Thread Tools Display Modes
Old 12-12-2017, 04:33 PM   #1
Senior Member
 
Join Date: Feb 2013
Location: plymouth ma
Posts: 131
backup camera

have a 2013 sunseeker 3050s and every time it rains, my backup camera fails to work. once it dries out, it works fine. has anyone had this problem and how did you solve the problem of water entering the unit. the company will send me a new one for hundred dollars and i would have to rewire the system ,must be a better way thanks in advance for any help oldnewguy
__________________

__________________
oldnewguy is offline   Reply With Quote
Old 12-14-2017, 12:39 PM   #2
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,335
There is an o-ring type seal between the camera housing halves. The screws may be loose holding the halves together or you might be getting water through the grommet where the cable enters. I had the same issue and finally replaced the camera.
__________________
2014 Solera 24R
USN Retired
Mikegjax is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:04 PM.