Reply
 
Thread Tools Display Modes
Old 11-09-2014, 01:28 PM   #1
Senior Member
 
rsscully's Avatar
 
Join Date: Aug 2014
Posts: 183
Onan generator hour meter.

My generator has very low hours on it, maybe 30. The last two times I have run it the hour meter has not worked. The hour meter does not show anything anymore. Pulled the panel and have ~12 volts on either side of the meter when not running. When I have the genny running I only have ~12 volts on one side of the meter. Is this normal? Any ideas? Is the meter just bad?
__________________

__________________
rsscully is offline   Reply With Quote
Old 11-09-2014, 03:37 PM   #2
Senior Member
 
Join Date: Aug 2014
Posts: 258
On side should be positive..other side ground.. You should only have 12 volts when gen set is running...
__________________

__________________
2010 Georgetown 300FWSSouth Florida
speedjester is offline   Reply With Quote
Old 11-09-2014, 03:40 PM   #3
Senior Member
 
Join Date: Aug 2014
Posts: 258
This may help..

http://www.justanswer.com/small-engi...eter-does.html
__________________
2010 Georgetown 300FWSSouth Florida
speedjester is offline   Reply With Quote
Old 11-09-2014, 04:32 PM   #4
Senior Member
 
rsscully's Avatar
 
Join Date: Aug 2014
Posts: 183
Thanks Jester. I actually read that already. The light works, the terminals have voltage but no display.
__________________
rsscully is offline   Reply With Quote
Old 11-09-2014, 04:58 PM   #5
Senior Member
 
Join Date: Aug 2014
Posts: 258
Is your gauge analog or digital?
__________________
2010 Georgetown 300FWSSouth Florida
speedjester is offline   Reply With Quote
Old 11-09-2014, 05:08 PM   #6
Senior Member
 
rsscully's Avatar
 
Join Date: Aug 2014
Posts: 183
Digital.

T44 Series LCD Hourmeter, EEPROM Memory On ENM Company
__________________
rsscully is offline   Reply With Quote
Old 11-09-2014, 05:13 PM   #7
Senior Member
 
Join Date: Aug 2014
Posts: 258
What I find strange is you have 12 volts on both sides... I don't believe you should have any power to the gauge unless unit is running....
__________________
2010 Georgetown 300FWSSouth Florida
speedjester is offline   Reply With Quote
Old 11-09-2014, 05:26 PM   #8
Senior Member
 
Join Date: Aug 2014
Posts: 258
Do you have a hr meter on gen set it self... Is the dc fuse intact?
__________________
2010 Georgetown 300FWSSouth Florida
speedjester is offline   Reply With Quote
Old 11-09-2014, 08:04 PM   #9
Senior Member
 
Join Date: Nov 2013
Location: Ooltewah, TN
Posts: 144
It's possible that starting the generator applies a ground to the negative side of the meter. If that is the case you would read 12V on both sides when the generator is not running. I think you have a bad meter.
__________________
David, Sherry and our three fur kids, Nicholas, Finnegan and Bentley
2013 Coachmen Encounter 36BH
2014 Honda CR-V/ Blue Ox Autostop
DSurette is offline   Reply With Quote
Old 11-09-2014, 09:36 PM   #10
Senior Member
 
Join Date: Feb 2012
Posts: 956
x2 on a bad meter.
__________________

__________________
ATVer is offline   Reply With Quote
Reply

Tags
generator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:32 AM.