Reply
 
Thread Tools Display Modes
Old 05-30-2013, 02:20 PM   #1
Senior Member
 
stonekeepers's Avatar
 
Join Date: Oct 2012
Location: Middle Tennessee
Posts: 142
Rear camera problems

We have a 2011 sun seeker 3010ds Spent last week camping in the North Carolina mountains and everything was great. When we cranked up the camper to head home the camera would not come on.

It appears to be totally dead. The remote does nothing and the power button on the display does nothing. We unplugged the connector next to the display and reseated it. It beeped a bit but nothing on the display. There is no manual for this camera but it looks like a factory install.

Any ideas on what we can do ? It's no fun towing our car and not being able to see it.
__________________

__________________
Let's Motor!!!

stonekeepers is offline   Reply With Quote
Old 05-30-2013, 03:14 PM   #2
GM
 
bclemens's Avatar
 
Join Date: May 2011
Location: Elkhart, IN
Posts: 7,067
Not sure if we were using the RVS system back then or not. It's about the same time that we switched over to RVS from another supplier.

Here are a couple of manuals. not sure if it will help. Knowing which camera it is would help.
Attached Files
File Type: pdf M45TC-IM.pdf (244.9 KB, 143 views)
File Type: pdf RVS Systems Rear View Camera RVS-770616N.pdf (1.24 MB, 145 views)
__________________

__________________
PLEASE do not send questions via Private Message. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only. Our owners manuals are available online and via iPhone/Android Apps. http://www.dynamaxcorp.com/OnlineManual.aspx
bclemens is offline   Reply With Quote
Old 05-30-2013, 03:32 PM   #3
Senior Member
 
stonekeepers's Avatar
 
Join Date: Oct 2012
Location: Middle Tennessee
Posts: 142
On the back it says model IRM-60-OM. It has a serial number and says "Made in China". Does that help?
__________________
Let's Motor!!!

stonekeepers is offline   Reply With Quote
Old 05-30-2013, 04:11 PM   #4
GM
 
bclemens's Avatar
 
Join Date: May 2011
Location: Elkhart, IN
Posts: 7,067
That might be from the Forest River electronics division. Basically another division. We treat them like any other supplier, we now buy from another division. You'd have to contact your dealer on that one. Hopefully its still inside of a year.
__________________
PLEASE do not send questions via Private Message. Post questions in the forum as a new thread so that other users can benefit from the answers. Use Private Messages for sensitive information only. Our owners manuals are available online and via iPhone/Android Apps. http://www.dynamaxcorp.com/OnlineManual.aspx
bclemens is offline   Reply With Quote
Old 05-30-2013, 04:28 PM   #5
Senior Member
 
stonekeepers's Avatar
 
Join Date: Oct 2012
Location: Middle Tennessee
Posts: 142
Quote:
Originally Posted by bclemens View Post
That might be from the Forest River electronics division. Basically another division. We treat them like any other supplier, we now buy from another division. You'd have to contact your dealer on that one. Hopefully its still inside of a year.
It's a 2011 so not within a year. We did have some sort of extended warranty. I was hoping it was some kind of easy fix like a loose connection. It did this one time before and magically started working again. We thought that may have been because it was cold and raining. Not the case today.

I will contact the dealer and see how to use the warranty. Thanks for your help. :-)
__________________
Let's Motor!!!

stonekeepers is offline   Reply With Quote
Old 06-30-2013, 10:16 AM   #6
2011 Sunseeker 3120
 
Garbet's Avatar
 
Join Date: Sep 2011
Location: Ontario, Canada
Posts: 24
Good morning Stonekeepers. I've been having same problem, would work one day, then not the next! Now, nothing. Were you able to find out any information about that particular rear view backup camera?

Gary
__________________
Garbet is offline   Reply With Quote
Old 06-30-2013, 11:32 AM   #7
Senior Member
 
stonekeepers's Avatar
 
Join Date: Oct 2012
Location: Middle Tennessee
Posts: 142
Nope. Ours still does not work. We have been on the road and a long way from a dealer so have not really done anything. I think it is most likely a wiring issue.
__________________
Let's Motor!!!

stonekeepers is offline   Reply With Quote
Old 06-30-2013, 07:18 PM   #8
2011 Sunseeker 3120
 
Garbet's Avatar
 
Join Date: Sep 2011
Location: Ontario, Canada
Posts: 24
Would be nice to know which brand we actually have in or unit!

Gary
__________________

__________________
Garbet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:07 AM.