Thread Tools Display Modes
Old 08-31-2014, 09:39 AM   #11
Senior Member
Join Date: Oct 2012
Location: Cobbs Creek, VA
Posts: 201
Ours died about a year ago, problem was a fuze found in the wiring behind the dash. Repair guy measured current draw and its ok so replaced the fuze and worked okay since

Geri is offline   Reply With Quote
Old 08-31-2014, 09:30 PM   #12
Terrie's Avatar
Join Date: Oct 2013
Location: Charlotte MI
Posts: 54
My rear works great. Been having problems with right turn signal camera. Works first time I use it then either is a pink screen or believe it or not a SAVED picture?? One time on hwy turned on signal & it was a picture of a driveway & mailbox. Very strange!

Sent by Forest River Forums

Terrie is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:30 AM.